aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2023-10-16 14:06:38 +0200
committerDavid Roman <davidroman96@gmail.com>2023-10-16 14:06:38 +0200
commitb83a377f3482f20b283eacc9527927f742c4bf45 (patch)
tree95c26a3104c7caf7d437229cca713612490fc6ee /dev-embedded/idf-component-manager
parentdev-embedded/idf-component-manager: drop 1.3.1 (diff)
downloadguru-b83a377f3482f20b283eacc9527927f742c4bf45.tar.gz
guru-b83a377f3482f20b283eacc9527927f742c4bf45.tar.bz2
guru-b83a377f3482f20b283eacc9527927f742c4bf45.zip
dev-embedded/idf-component-manager: fix tests
Closes: https://bugs.gentoo.org/910095 Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-embedded/idf-component-manager')
-rw-r--r--dev-embedded/idf-component-manager/idf-component-manager-1.3.2-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-embedded/idf-component-manager/idf-component-manager-1.3.2-r1.ebuild b/dev-embedded/idf-component-manager/idf-component-manager-1.3.2-r1.ebuild
new file mode 100644
index 000000000..9cbe5904b
--- /dev/null
+++ b/dev-embedded/idf-component-manager/idf-component-manager-1.3.2-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_11 )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Tool for installing ESP-IDF components"
+HOMEPAGE="https://github.com/espressif/idf-component-manager"
+SRC_URI="https://github.com/espressif/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+RDEPEND="
+ dev-python/cachecontrol[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/requests-file[${PYTHON_USEDEP}]
+ dev-python/schema[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ <dev-python/urllib3-2.0.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest