aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Roman <davidroman96@gmail.com>2024-10-29 15:48:33 +0100
committerDavid Roman <davidroman96@gmail.com>2024-10-29 15:48:33 +0100
commit96fba04860d08bfb4ee4bae2057b649df8211723 (patch)
treedb07ee93a40a10898bfe9a6fffb7c4cbb0444bcf /dev-embedded/idf-component-manager
parentsys-fs/dwarfs: add missing dev-cpp/range-v3 dependency to prevent it from bei... (diff)
downloadguru-96fba04860d08bfb4ee4bae2057b649df8211723.tar.gz
guru-96fba04860d08bfb4ee4bae2057b649df8211723.tar.bz2
guru-96fba04860d08bfb4ee4bae2057b649df8211723.zip
dev-embedded/idf-component-manager: add 2.0.4
Signed-off-by: David Roman <davidroman96@gmail.com>
Diffstat (limited to 'dev-embedded/idf-component-manager')
-rw-r--r--dev-embedded/idf-component-manager/Manifest1
-rw-r--r--dev-embedded/idf-component-manager/idf-component-manager-2.0.4.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-embedded/idf-component-manager/Manifest b/dev-embedded/idf-component-manager/Manifest
index 685bb6ee1..a8e6274dd 100644
--- a/dev-embedded/idf-component-manager/Manifest
+++ b/dev-embedded/idf-component-manager/Manifest
@@ -1 +1,2 @@
DIST idf-component-manager-2.0.3.gh.tar.gz 322831 BLAKE2B 8456e2f4bb3e4b221aba4c946b7f2a980c36a8796e7fd7a53b97c76fd68f1462f92943bfb185d0dea4ae1792fe91f58527812ec5d81a19462e978fb2625bf2b6 SHA512 632bef699b8164b05d6cd5b0cc93cce28a1f8ec86b3fc2f58989f872ac556af3c8f7ea28d4966880ee3bca64ebb1169a819d4e46652e978e8a3bfab38ae52a02
+DIST idf-component-manager-2.0.4.gh.tar.gz 325170 BLAKE2B 813ec539fc3d48a51dc6378e3a2922cd996c56472091a5d58775c8d67c046acbdf87741ef0ccf69d8c00fcf7e684a5117134a146d55145ea59359a55cead76e1 SHA512 5160c3e0a580d499ce722966f166a87e2029b15e1e60566d8b2d063217e9bc156ecf47908800a270e75d8de25494b74efdf5cd859536e76bd717065f0d1fb4c4
diff --git a/dev-embedded/idf-component-manager/idf-component-manager-2.0.4.ebuild b/dev-embedded/idf-component-manager/idf-component-manager-2.0.4.ebuild
new file mode 100644
index 000000000..0ec7c25c8
--- /dev/null
+++ b/dev-embedded/idf-component-manager/idf-component-manager-2.0.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{11..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Tool for installing ESP-IDF components"
+HOMEPAGE="https://github.com/espressif/idf-component-manager"
+SRC_URI="https://github.com/espressif/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )
+"
+
+RDEPEND="
+ dev-python/cachecontrol[${PYTHON_USEDEP}]
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/jsonref[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pydantic-settings[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/requests-file[${PYTHON_USEDEP}]
+ dev-python/schema[${PYTHON_USEDEP}]
+ dev-python/tqdm[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+
+# Requires additional files not available in the tarball
+EPYTEST_DESELECT=(
+ tests/test_component_manager.py::test_pack_component_with_examples_errors
+ tests/test_component_manager.py::test_pack_component_with_dest_dir
+ tests/test_profile.py::TestMultiStorageClient::test_registry_storage_url
+ tests/test_profile.py::TestMultiStorageClient::test_storage_clients_precedence
+)
+
+# network access
+EPYTEST_IGNORE=(
+ tests/test_api_client.py
+ tests/test_prepare_dep_dirs.py
+)
+
+distutils_enable_tests pytest