aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2021-04-30 23:17:27 +1200
committerTheo Anderson <telans@posteo.de>2021-04-30 23:17:59 +1200
commit4bfca52ca35af352270d7ffc2d93ecc1c853dd19 (patch)
treeb546fb91d91f7ffee3b461b368979749a80c81fd /dev-dotnet
parentprofiles: dev-dotnet new category (diff)
downloadguru-4bfca52ca35af352270d7ffc2d93ecc1c853dd19.tar.gz
guru-4bfca52ca35af352270d7ffc2d93ecc1c853dd19.tar.bz2
guru-4bfca52ca35af352270d7ffc2d93ecc1c853dd19.zip
dev-dotnet/dotnet-runtime-bin: initial import
Signed-off-by: Theo Anderson <telans@posteo.de>
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/dotnet-runtime-bin/Manifest3
-rw-r--r--dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-5.0.5.ebuild50
-rw-r--r--dev-dotnet/dotnet-runtime-bin/files/80dotnet2
-rw-r--r--dev-dotnet/dotnet-runtime-bin/metadata.xml8
4 files changed, 63 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-runtime-bin/Manifest b/dev-dotnet/dotnet-runtime-bin/Manifest
new file mode 100644
index 000000000..92e6c2069
--- /dev/null
+++ b/dev-dotnet/dotnet-runtime-bin/Manifest
@@ -0,0 +1,3 @@
+DIST dotnet-runtime-5.0.5-linux-arm.tar.gz 28939822 BLAKE2B 7b0d311789624e94943c5fbfa3df76992b43dd12fb838f9af427e12c2b0f91027e1263265a59ecf43652cf711f36c1ac6518bf8d6b5aa0d93fabde81a81fffb2 SHA512 b7032a935a808370b1eedad7d3e7204c4d05518d21be5aa0b990bf935b48cc89ed70d2fcb282a5ae191034722bc09dfcbc12e2ad674b37c8bd23db8811cde3cb
+DIST dotnet-runtime-5.0.5-linux-arm64.tar.gz 28659540 BLAKE2B 1633092a1344a8e293e2382bcbec0ca55c9fceb6214ec6d14f3b4beca301d7941a43fc80cf1eee63aad87579d6721a6497c20ab0da0b2532295af0bede902e3c SHA512 d3ea167e1877f6a30ed3e2243bfde572340db295cdc2fe91a6035bfaaab4b15a42023bbef79db3cdbc8cf32a24efd91d53975701c8068cbcc0a51965a70efdee
+DIST dotnet-runtime-5.0.5-linux-x64.tar.gz 30858909 BLAKE2B 7d4b777045e58793cc57b25e7b111b2f8affde574dd7f7ccd9b76b827b2c23139f9a0a4150ec83ba47a7d1419df35addecc53bb992fe9edb3ba7812c56ef28f2 SHA512 ce9d3778c9a331b35cf18d7b64f9eec8fc37d9088f1a2208488577f611b2ab0f8b3a82b7f559b331d584ac86e1f09153ee2e255e617239fe9a9382373f873237
diff --git a/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-5.0.5.ebuild b/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-5.0.5.ebuild
new file mode 100644
index 000000000..3bcb44373
--- /dev/null
+++ b/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-5.0.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION=".NET Runtime"
+HOMEPAGE="https://dotnet.microsoft.com/"
+SRC_URI="
+ amd64? ( https://dotnetcli.azureedge.net/dotnet/Runtime/${PV}/dotnet-runtime-${PV}-linux-x64.tar.gz )
+ arm? ( https://dotnetcli.azureedge.net/dotnet/Runtime/${PV}/dotnet-runtime-${PV}-linux-arm.tar.gz )
+ arm64? ( https://dotnetcli.azureedge.net/dotnet/Runtime/${PV}/dotnet-runtime-${PV}-linux-arm64.tar.gz )
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64"
+
+# The SDK includes dotnet-runtime-bin so prevent installing the SDK at the same time
+RDEPEND="
+ app-crypt/mit-krb5
+ !dev-dotnet/dotnet-sdk-bin
+ !dev-dotnet/dotnet-sdk-bin-common
+ dev-libs/icu
+ dev-util/lldb
+ dev-util/lttng-ust
+ net-misc/curl
+ sys-apps/lsb-release
+ sys-devel/llvm
+ sys-libs/zlib
+ || (
+ dev-libs/openssl
+ dev-libs/openssl-compat
+ )
+ || (
+ sys-libs/libunwind
+ sys-libs/llvm-libunwind
+ )
+"
+
+QA_PREBUILT="*"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /opt/dotnet
+ doins -r "${S}/."
+ dosym ../../opt/dotnet/dotnet /usr/bin/dotnet
+ fperms +x /usr/bin/dotnet
+ doenvd "${FILESDIR}/80dotnet"
+}
diff --git a/dev-dotnet/dotnet-runtime-bin/files/80dotnet b/dev-dotnet/dotnet-runtime-bin/files/80dotnet
new file mode 100644
index 000000000..4cf0206ea
--- /dev/null
+++ b/dev-dotnet/dotnet-runtime-bin/files/80dotnet
@@ -0,0 +1,2 @@
+DOTNET_CLI_TELEMETRY_OPTOUT=1
+DOTNET_ROOT=/opt/dotnet
diff --git a/dev-dotnet/dotnet-runtime-bin/metadata.xml b/dev-dotnet/dotnet-runtime-bin/metadata.xml
new file mode 100644
index 000000000..17cfe1629
--- /dev/null
+++ b/dev-dotnet/dotnet-runtime-bin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>telans@posteo.de</email>
+ <name>Theo Anderson</name>
+ </maintainer>
+</pkgmetadata>