aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-09 12:54:22 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-09 12:54:22 +0500
commitc55cec6ca9506d2bf036240c156b4a92c58908b2 (patch)
treec227fb6f66562584c5dafda664f77a93ea85a3d7 /dev-crystal
parentcrystal-utils.eclass: introduce mycrystalargs (diff)
downloadguru-c55cec6ca9506d2bf036240c156b4a92c58908b2.tar.gz
guru-c55cec6ca9506d2bf036240c156b4a92c58908b2.tar.bz2
guru-c55cec6ca9506d2bf036240c156b4a92c58908b2.zip
dev-crystal/protodec: new package, add 0.1.4
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-crystal')
-rw-r--r--dev-crystal/protodec/Manifest1
-rw-r--r--dev-crystal/protodec/metadata.xml8
-rw-r--r--dev-crystal/protodec/protodec-0.1.4.ebuild30
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-crystal/protodec/Manifest b/dev-crystal/protodec/Manifest
new file mode 100644
index 000000000..65dc7e777
--- /dev/null
+++ b/dev-crystal/protodec/Manifest
@@ -0,0 +1 @@
+DIST protodec-0.1.4.tar.gz 18008 BLAKE2B e3154c4901df523e8a914a23006030448ffc8c926701d5a072f1f0278b1e17969d83049bf4c49037af1f05eb1ececb0e79d5080e47e181ed944690daffa75957 SHA512 0211c7b165946d2779808a43893703bf0138ff601e0e3b4aa54024b5eed317d692547822dc42ec6b320f75798ffa4334c4217fd1ee5c11b1eb6dab6db20ce7a8
diff --git a/dev-crystal/protodec/metadata.xml b/dev-crystal/protodec/metadata.xml
new file mode 100644
index 000000000..7ebbd0334
--- /dev/null
+++ b/dev-crystal/protodec/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-crystal/protodec/protodec-0.1.4.ebuild b/dev-crystal/protodec/protodec-0.1.4.ebuild
new file mode 100644
index 000000000..f299a6362
--- /dev/null
+++ b/dev-crystal/protodec/protodec-0.1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit shards
+
+DESCRIPTION="Command-line tool to encode and decode arbitrary protobuf data"
+HOMEPAGE="https://github.com/iv-org/protodec"
+SRC_URI="https://github.com/iv-org/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ dev-libs/boehm-gc
+ dev-libs/libevent:=
+ dev-libs/libpcre
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i src/protodec.cr \
+ -e 's/\(CURRENT_BRANCH \) = .*/\1 = "master"/' \
+ -e 's/\(CURRENT_COMMIT \) = .*/\1 = "gentoo"/' \
+ -e "s/\(CURRENT_VERSION\) = .*/\1 = \"v${PV}\"/" || die
+}