aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-08 22:44:46 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2022-11-08 22:44:46 +0500
commitbb97facd744fb5188f05dbd8ed4c7be80d0d96c0 (patch)
treeb3b5cde76a40e72b0b75e0d8bb0138546422be76 /dev-crystal/crystal-pg
parentdev-crystal/crystal-sqlite3: new package, add 0.19.0 (diff)
downloadguru-bb97facd744fb5188f05dbd8ed4c7be80d0d96c0.tar.gz
guru-bb97facd744fb5188f05dbd8ed4c7be80d0d96c0.tar.bz2
guru-bb97facd744fb5188f05dbd8ed4c7be80d0d96c0.zip
dev-crystal/crystal-pg: new package, add 0.26.0
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'dev-crystal/crystal-pg')
-rw-r--r--dev-crystal/crystal-pg/Manifest1
-rw-r--r--dev-crystal/crystal-pg/crystal-pg-0.26.0.ebuild26
-rw-r--r--dev-crystal/crystal-pg/metadata.xml8
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-crystal/crystal-pg/Manifest b/dev-crystal/crystal-pg/Manifest
new file mode 100644
index 000000000..029d06a1f
--- /dev/null
+++ b/dev-crystal/crystal-pg/Manifest
@@ -0,0 +1 @@
+DIST crystal-pg-0.26.0.tar.gz 38901 BLAKE2B 954737db2ebfb02ad8ed7a071a2728199a306a8eb44a31bd7702413d271c8e9aec4d5ff104487d224e8278bb4d45fe619e8f84db930cd3c70a83a3487b6387bc SHA512 097450dbabb2c2d26deb70a9ed34f49f70e63e59055b5b3513eab9951feca546886998263848c7b7648bad716f6d67b436d1bde5ff0a89d521520350138055c1
diff --git a/dev-crystal/crystal-pg/crystal-pg-0.26.0.ebuild b/dev-crystal/crystal-pg/crystal-pg-0.26.0.ebuild
new file mode 100644
index 000000000..1079b9ea5
--- /dev/null
+++ b/dev-crystal/crystal-pg/crystal-pg-0.26.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit databases shards
+
+DESCRIPTION="A native, non-blocking Postgres driver for Crystal"
+HOMEPAGE="https://github.com/will/crystal-pg"
+SRC_URI="https://github.com/will/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="dev-crystal/crystal-db"
+
+DOCS=( CHANGELOG CONTRIBUTORS {CONTRIBUTING,README}.md )
+
+src_test() {
+ local -x DATABASE_URL="postgres://postgres@127.0.0.1:65432"
+
+ epostgres --start 65432
+ shards_src_test
+ epostgres --stop
+}
diff --git a/dev-crystal/crystal-pg/metadata.xml b/dev-crystal/crystal-pg/metadata.xml
new file mode 100644
index 000000000..7ebbd0334
--- /dev/null
+++ b/dev-crystal/crystal-pg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+</pkgmetadata>