aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2023-02-28 17:22:24 +0500
committerDenis Reva <denis7774@gmail.com>2023-02-28 17:57:43 +0500
commit5dc6a108df0ec64ff1acd0c8983a00d801eea4e0 (patch)
tree679a106f1b632fc380d58d962513d79ca3f051ec /dev-cpp
parentdev-cpp/wangle: Unorphaned and updated (diff)
downloadguru-5dc6a108df0ec64ff1acd0c8983a00d801eea4e0.tar.gz
guru-5dc6a108df0ec64ff1acd0c8983a00d801eea4e0.tar.bz2
guru-5dc6a108df0ec64ff1acd0c8983a00d801eea4e0.zip
dev-cpp/fbthrift: Unorphaned and updated
Signed-off-by: Denis Reva <denis7774@gmail.com>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/fbthrift/Manifest1
-rw-r--r--dev-cpp/fbthrift/fbthrift-2023.02.06.00.ebuild47
-rw-r--r--dev-cpp/fbthrift/metadata.xml20
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-cpp/fbthrift/Manifest b/dev-cpp/fbthrift/Manifest
new file mode 100644
index 000000000..44fcaa583
--- /dev/null
+++ b/dev-cpp/fbthrift/Manifest
@@ -0,0 +1 @@
+DIST fbthrift-2023.02.06.00.tar.gz 13447174 BLAKE2B d8a931dc4ded159ca1b1b1aa9db7d97c7f6fc3842fe59873c72125acf93c572bb4f31d5514b237166fb7108e746f7473bc50e62becab93411b01d8988cb53534 SHA512 a726cc3276c623471129ba7822926e311f455a1c90cc2be9a5506310563609c9843dcb0b6852c288e766a6268bb01e0db8d0a67b6c3f01fc9fd84ff58a479ba6
diff --git a/dev-cpp/fbthrift/fbthrift-2023.02.06.00.ebuild b/dev-cpp/fbthrift/fbthrift-2023.02.06.00.ebuild
new file mode 100644
index 000000000..ac597c130
--- /dev/null
+++ b/dev-cpp/fbthrift/fbthrift-2023.02.06.00.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Facebook's branch of Apache Thrift, including a new C++ server"
+HOMEPAGE="https://github.com/facebook/fbthrift"
+SRC_URI="https://github.com/facebook/fbthrift/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-arch/zstd
+ >=dev-cpp/fizz-${PV}:=
+ >=dev-cpp/folly-${PV}:=
+ dev-cpp/gflags
+ dev-cpp/glog
+ >=dev-cpp/wangle-${PV}:=
+ dev-libs/boost
+ dev-libs/libfmt
+ dev-libs/openssl:0=
+ sys-libs/zlib
+ ${PYTHON_DEPS}
+"
+DEPEND="
+ ${RDEPEND}
+ $(python_gen_cond_dep 'dev-python/six[${PYTHON_USEDEP}]')
+"
+BDEPEND="
+ sys-devel/bison
+ sys-devel/flex
+"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake_src_configure
+}
diff --git a/dev-cpp/fbthrift/metadata.xml b/dev-cpp/fbthrift/metadata.xml
new file mode 100644
index 000000000..ed3a5f3fb
--- /dev/null
+++ b/dev-cpp/fbthrift/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM 'http://www.gentoo.org/dtd/metadata.dtd'>
+<pkgmetadata>
+ <maintainer type="person">
+ <email>denis7774@gmail.com</email>
+ <name>Denis Reva</name>
+ <description>rarogcmex</description>
+ </maintainer>
+ <longdescription lang="en">
+Thrift is a serialization and RPC framework for service communication. Thrift enables these features in all major languages, and there is strong support for C++, Python, Hack, and Java. Most services at Facebook are written using Thrift for RPC, and some storage systems use Thrift for serializing records on disk.
+
+Facebook Thrift is not a distribution of Apache Thrift. This is an evolved internal branch of Thrift that Facebook re-released to open source community in February 2014. Facebook Thrift was originally released closely tracking Apache Thrift but is now evolving in new directions. In particular, the compiler was rewritten from scratch and the new implementation features a fully asynchronous Thrift server. Read more about these improvements in the ThriftServer documentation.
+
+You can also learn more about this project in the original Facebook Code blog post.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/facebook/fbthrift/issues</bugs-to>
+ <remote-id type="github">facebook/fbthrift</remote-id>
+ </upstream>
+</pkgmetadata>