aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKamal Abdellatif <gentoo.kamal@tgf.pw>2023-02-13 10:26:09 +0000
committerKamal Abdellatif <gentoo.kamal@tgf.pw>2023-02-13 15:43:05 +0000
commit31ba3a34b8c40f7bd68c5998640fac8e4da2930e (patch)
treed78aec6a60edda0d7f3aac3b9bd2f4c176af4ca1 /dev-cpp
parentgames-emulation/flycast: support lasted glslang, force system sdl (diff)
downloadguru-31ba3a34b8c40f7bd68c5998640fac8e4da2930e.tar.gz
guru-31ba3a34b8c40f7bd68c5998640fac8e4da2930e.tar.bz2
guru-31ba3a34b8c40f7bd68c5998640fac8e4da2930e.zip
dev-cpp/xtl: move tests out of src_compile
Signed-off-by: Kamal Abdellatif <gentoo.kamal@tgf.pw>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/xtl/xtl-0.7.5.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/dev-cpp/xtl/xtl-0.7.5.ebuild b/dev-cpp/xtl/xtl-0.7.5.ebuild
index b1a9cf5da..939a65d5f 100644
--- a/dev-cpp/xtl/xtl-0.7.5.ebuild
+++ b/dev-cpp/xtl/xtl-0.7.5.ebuild
@@ -47,11 +47,13 @@ src_configure() {
}
src_compile() {
- use test && cmake_src_compile xtest
-
if use doc; then
cd "${WORKDIR}/${P}/docs" || die
emake html BUILDDIR="${BUILD_DIR}"
HTML_DOCS=( "${BUILD_DIR}/html/." )
fi
}
+
+src_test() {
+ cmake_src_compile xtest
+}