aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-01-29 12:33:06 +0100
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2023-01-29 12:39:06 +0100
commit27c6a433576bbad6b65da41749b242d3522f6fd8 (patch)
tree709b78ba2ae3ff10cd32c09d8e92b0fc00d408f9 /dev-cpp
parentgames-engines/easyrpg-player: new package, add 0.7.0 (diff)
downloadguru-27c6a433576bbad6b65da41749b242d3522f6fd8.tar.gz
guru-27c6a433576bbad6b65da41749b242d3522f6fd8.tar.bz2
guru-27c6a433576bbad6b65da41749b242d3522f6fd8.zip
dev-cpp/trantor: add 1.5.10
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/trantor/Manifest1
-rw-r--r--dev-cpp/trantor/trantor-1.5.10.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-cpp/trantor/Manifest b/dev-cpp/trantor/Manifest
index 8dda1ccad..3d3abd4fa 100644
--- a/dev-cpp/trantor/Manifest
+++ b/dev-cpp/trantor/Manifest
@@ -1,2 +1,3 @@
+DIST trantor-1.5.10.tar.gz 112413 BLAKE2B 7ee04f57ba6f41edcc4c5334c63c7194e8a581edaec771ca6a2b2f6c444603da7a43d5ebf30ac89b9302f4302c4a54af9cee3c9532545345f0bf51b56b95dae3 SHA512 27ddc46b81747ba43f2abb5d6f3b82257ee6a7295f3cca3da0320dea2e6ef4b6276641a3fc3f61a082aa7ea360ee56663cebf4c6301ba79dcdbbdc96a450cb28
DIST trantor-1.5.7.tar.gz 112139 BLAKE2B f0584b762c9c4f4e34eaec06f7438ef9bc587f5f6333ee9ee26a8c65f60bafc159f1b9b52a9079d5454824ec0911015274c4dcedaf102d1a09b3edc6a9cf06d5 SHA512 52fe66a5eb4a682abffe90b69b5ebf4f5791d07e020bf8bbe88317b3fddbc9f3c04b6a2664aa3ca1851c5c9681433f99e3851458bb9a99be89452382ca33e837
DIST trantor-1.5.8.tar.gz 112315 BLAKE2B ee7b1805005fe33c8820fe84adf2af23a12e3758646fe18e681e2fc7a89109546f9bfa2b64cc03fd667a3d78d70377da31dfad67f76269b9afa3d9659163fee4 SHA512 6c90d3dbbc4e175500dfa8365dd42b1e260c5401b6551fb8f28e3673a6540b0937a66ca9f2ae0cc1ef6b1ba27c6232a053ef5402e5ef36835a51f841354de5c9
diff --git a/dev-cpp/trantor/trantor-1.5.10.ebuild b/dev-cpp/trantor/trantor-1.5.10.ebuild
new file mode 100644
index 000000000..85df49d01
--- /dev/null
+++ b/dev-cpp/trantor/trantor-1.5.10.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Non-blocking I/O tcp network lib based on c++14/17"
+HOMEPAGE="https://github.com/an-tao/trantor"
+SRC_URI="https://github.com/an-tao/trantor/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="adns doc +ssl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ adns? ( net-dns/c-ares:= )
+ ssl? ( dev-libs/openssl:= )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-cpp/gtest )
+"
+BDEPEND="doc? ( app-doc/doxygen[dot] )"
+
+src_prepare() {
+ sed -i 's/ -Werror)$/)/' CMakeLists.txt || die "could not remove -Werror"
+ cmake_src_prepare
+}
+
+src_configure() {
+ local -a mycmakeargs=(
+ "-DBUILD_SHARED_LIBS=YES"
+ "-DBUILD_DOC=$(usex doc)"
+ "-DBUILD_TESTING=$(usex test)"
+ "-DBUILD_C-ARES=$(usex adns)"
+ "$(cmake_use_find_package ssl OpenSSL)"
+ )
+
+ cmake_src_configure
+}
+
+src_install() {
+ use doc && HTML_DOCS="${BUILD_DIR}/docs/trantor/html/*"
+
+ cmake_src_install
+}