aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteffen Winter <steffen.winter@proton.me>2024-07-11 13:47:59 +0200
committerSteffen Winter <steffen.winter@proton.me>2024-07-11 13:47:59 +0200
commit1af2702f14a86a9a5f74bea63b23612f95472ba2 (patch)
tree6dc18c8377e8d3768de6fefaeb3ea44d34c6952e /dev-cpp/simdutf
parentx11-misc/i3status-rust: drop 0.32.3, 0.33.0 (diff)
downloadguru-1af2702f14a86a9a5f74bea63b23612f95472ba2.tar.gz
guru-1af2702f14a86a9a5f74bea63b23612f95472ba2.tar.bz2
guru-1af2702f14a86a9a5f74bea63b23612f95472ba2.zip
dev-cpp/simdutf: add 5.3.0
Signed-off-by: Steffen Winter <steffen.winter@proton.me>
Diffstat (limited to 'dev-cpp/simdutf')
-rw-r--r--dev-cpp/simdutf/Manifest1
-rw-r--r--dev-cpp/simdutf/simdutf-5.3.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-cpp/simdutf/Manifest b/dev-cpp/simdutf/Manifest
index 4bbc79887..71c3e7c45 100644
--- a/dev-cpp/simdutf/Manifest
+++ b/dev-cpp/simdutf/Manifest
@@ -1 +1,2 @@
DIST simdutf-5.2.8.tar.gz 1941240 BLAKE2B ce31343f83b96f4a5010e2373f2433db7d836d97ce81acc9d1babf5e47e2018f8789c3f810475e4c8181a470fafbe35b434c45d6de7a14e661b665f9e1514d14 SHA512 cd967640ce7a587ba7d0fbf1311bbced04beab341c03875f541179619e561773dffc8feb4b4e685ef549e7ae915b2bbd67f8b0100fd354d77ff0e068b896593f
+DIST simdutf-5.3.0.tar.gz 1945148 BLAKE2B ed542d2d82cbadd364e53ab53be42ef6bda66e9ad96aa379acc7995c825b53bf710ed3b8c2da41624ae16b75ac802c142ab4588add85fbd0df1e86194c91d9a7 SHA512 b4d1d50fcdb801a6c9b98869a3511ebc95bccb5b8ab08c60d8f9b27bd132b15b66c8a344d97327035c2800bab74a7889253d6e496d3d36b8f6cdab8d10ad58c6
diff --git a/dev-cpp/simdutf/simdutf-5.3.0.ebuild b/dev-cpp/simdutf/simdutf-5.3.0.ebuild
new file mode 100644
index 000000000..3875eae9b
--- /dev/null
+++ b/dev-cpp/simdutf/simdutf-5.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="simdutf: Unicode validation and transcoding at billions of characters per second"
+HOMEPAGE="https://simdutf.github.io/simdutf/"
+SRC_URI="https://github.com/simdutf/simdutf/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 MIT )"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+BDEPEND="${PYTHON_DEPS}"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=( -DSIMDUTF_TESTS=$(usex test ON OFF) )
+ cmake_src_configure
+}