aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-08-18 02:31:29 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2021-08-18 02:31:29 +0500
commitdf38767006cd2df0c5f2d68fe71783928014d9d5 (patch)
treeb48a1e0dd88bf3d92faf5668b242d53e0763a544 /app-vim
parentapp-vim/tex-conceal: initial import (diff)
downloadguru-df38767006cd2df0c5f2d68fe71783928014d9d5.tar.gz
guru-df38767006cd2df0c5f2d68fe71783928014d9d5.tar.bz2
guru-df38767006cd2df0c5f2d68fe71783928014d9d5.zip
app-vim/rainbow: initial import
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/rainbow/Manifest1
-rw-r--r--app-vim/rainbow/files/README.gentoo8
-rw-r--r--app-vim/rainbow/metadata.xml8
-rw-r--r--app-vim/rainbow/rainbow-3.4.0_p20200528.ebuild29
4 files changed, 46 insertions, 0 deletions
diff --git a/app-vim/rainbow/Manifest b/app-vim/rainbow/Manifest
new file mode 100644
index 000000000..e4db4d297
--- /dev/null
+++ b/app-vim/rainbow/Manifest
@@ -0,0 +1 @@
+DIST rainbow-3.4.0_p20200528.tar.gz 14901 BLAKE2B c6e5f2ab3fc16fe0cf2e00429027416d516a08ada49fb24207f8f0a410b3b29ffee6f6eab74f8f8f8be6425e28dc61fe52d994dc020b457c10aa0b4524b6ab68 SHA512 e91e0b969d46dc2507cfcdfd8e9ceea26e863ecf2a532b51129744e961c383c24d63e2a213cfffbad22c278d65652aff9c97afcfe6f271ffd60d9a57305a0948
diff --git a/app-vim/rainbow/files/README.gentoo b/app-vim/rainbow/files/README.gentoo
new file mode 100644
index 000000000..bccf810dd
--- /dev/null
+++ b/app-vim/rainbow/files/README.gentoo
@@ -0,0 +1,8 @@
+CMakeLists.txt syntax highlighting is broken with rainbow enabled.
+Add this to your vimrc to work around the bug:
+
+let g:rainbow_conf = {
+\ 'separately': {
+\ 'cmake': 0,
+\ }
+\}
diff --git a/app-vim/rainbow/metadata.xml b/app-vim/rainbow/metadata.xml
new file mode 100644
index 000000000..c8b0192e7
--- /dev/null
+++ b/app-vim/rainbow/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cyber+gentoo@sysrq.in</email>
+ <name>Anna</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/rainbow/rainbow-3.4.0_p20200528.ebuild b/app-vim/rainbow/rainbow-3.4.0_p20200528.ebuild
new file mode 100644
index 000000000..99ee0ff97
--- /dev/null
+++ b/app-vim/rainbow/rainbow-3.4.0_p20200528.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit readme.gentoo-r1 vim-plugin
+
+COMMIT="4d15633cdaf61602e1d9fd216a77fc02e0881b2d"
+DESCRIPTION="vim plugin: Rainbow Parentheses Improved"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=4176
+https://github.com/luochen1990/rainbow"
+SRC_URI="https://github.com/luochen1990/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="rainbow"
+
+src_install() {
+ rm -r tests || die
+ vim-plugin_src_install
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ readme.gentoo_print_elog
+}