aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-03-20 00:00:14 +0500
committerAnna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>2023-03-20 00:07:34 +0500
commit14583edc07124ee53a99f377c3fff1cda3d5f0e5 (patch)
treeb7ebd177097f9fa7cf2447fb081f89eaa9efb3b0 /app-vim
parentapp-vim/css-color: add 20230308 (diff)
downloadguru-14583edc07124ee53a99f377c3fff1cda3d5f0e5.tar.gz
guru-14583edc07124ee53a99f377c3fff1cda3d5f0e5.tar.bz2
guru-14583edc07124ee53a99f377c3fff1cda3d5f0e5.zip
app-vim/vim-crystal: add 2023.03.15
Signed-off-by: Anna (cybertailor) Vyalkova <cyber+gentoo@sysrq.in>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vim-crystal/Manifest1
-rw-r--r--app-vim/vim-crystal/vim-crystal-2023.03.15.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-vim/vim-crystal/Manifest b/app-vim/vim-crystal/Manifest
index d05b4feddc..98fd51fa45 100644
--- a/app-vim/vim-crystal/Manifest
+++ b/app-vim/vim-crystal/Manifest
@@ -1 +1,2 @@
DIST vim-crystal-2022.09.04.tar.gz 42137 BLAKE2B 141fb2351c49f5fecad5b7dc2eb15b3308302e99634f51051f8482a49863a4a4fa2a1a07c4beb99de667e6c65efa52a6e6a1812bd8c4cad40d749afe873ffb5e SHA512 cb772f2728a6a98c37d6698b198b9149d34d01b02121faf581ebacb46ba6e810e24efd48fe7b199e6b3736130010650944129c68d63d7e81ebfa84638bdc6a71
+DIST vim-crystal-2023.03.15.tar.gz 42168 BLAKE2B 447560748a69f82cf35a4a3f6e1082d8a221522ae04dbfc0941964814e9f91b8c45e6a85ce85c5edbf85d4b1d1e04b7f45ec45f7da54221a2c1187dda910f9f9 SHA512 5404e5823015b46a134098ca6fe13438e0555605996530623fec0314ab71949b2a47d5c9377e89fe50271b979b8434853f648fd6ec003bad1f2f1f480a6dab9d
diff --git a/app-vim/vim-crystal/vim-crystal-2023.03.15.ebuild b/app-vim/vim-crystal/vim-crystal-2023.03.15.ebuild
new file mode 100644
index 0000000000..dd36e665ec
--- /dev/null
+++ b/app-vim/vim-crystal/vim-crystal-2023.03.15.ebuild
@@ -0,0 +1,23 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature vim-plugin
+
+COMMIT="dc21188ec8c2ee77bb81dffca02e1a29d87cfd9f"
+DESCRIPTION="vim plugin: Crystal language support"
+HOMEPAGE="https://github.com/vim-crystal/vim-crystal"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+src_install() {
+ vim-plugin_src_install syntax_checkers
+}
+
+pkg_postinst() {
+ optfeature "syntax checking support" app-vim/syntastic
+}