aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos Eduardo <carana2099@gmail.com>2024-05-30 07:07:16 -0300
committerCarlos Eduardo <carana2099@gmail.com>2024-05-30 07:07:16 -0300
commitbbf25b4f2790290a7092f83630c17bb6aa12ab97 (patch)
tree34cdc0dfab485cb8a281d29cd0bafa431dc8242d /app-text
parentnet-misc/openbgpd: add 8.4, drop 8.0 (diff)
downloadguru-bbf25b4f2790290a7092f83630c17bb6aa12ab97.tar.gz
guru-bbf25b4f2790290a7092f83630c17bb6aa12ab97.tar.bz2
guru-bbf25b4f2790290a7092f83630c17bb6aa12ab97.zip
app-text/lchat: respect LDFLAGS 2.0
Closes: https://bugs.gentoo.org/932604 Signed-off-by: Carlos Eduardo <carana2099@gmail.com>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/lchat/lchat-1.0-r2.ebuild (renamed from app-text/lchat/lchat-1.0-r1.ebuild)5
1 files changed, 4 insertions, 1 deletions
diff --git a/app-text/lchat/lchat-1.0-r1.ebuild b/app-text/lchat/lchat-1.0-r2.ebuild
index 3e5bb2e11..3a094f1be 100644
--- a/app-text/lchat/lchat-1.0-r1.ebuild
+++ b/app-text/lchat/lchat-1.0-r2.ebuild
@@ -16,7 +16,10 @@ DEPEND="${RDEPEND}"
IUSE="+examples"
src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="$CFLAGS" LIBS="-lgrapheme $LDFLAGS" all $(usex examples filter/indent)
+ emake CC="$(tc-getCC)" CFLAGS="$CFLAGS" LIBS="-lgrapheme $LDFLAGS" all
+ if use examples; then
+ emake CC="$(tc-getCC)" CFLAGS="$CFLAGS $LDFLAGS" filter/indent
+ fi
}
src_install() {