aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-06-02 09:35:18 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-06-02 09:35:18 +0200
commit6e949053fc31bb12f90a0a00d954f21f42d885a5 (patch)
tree862640c863602ab98bca5e4d7f6c9dbb23bb1396 /app-text
parentdev-python/hwi: version bump to 2.0.2 (diff)
downloadguru-6e949053fc31bb12f90a0a00d954f21f42d885a5.tar.gz
guru-6e949053fc31bb12f90a0a00d954f21f42d885a5.tar.bz2
guru-6e949053fc31bb12f90a0a00d954f21f42d885a5.zip
app-text/epubgrep: Version bump 0.5.0.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/epubgrep/Manifest1
-rw-r--r--app-text/epubgrep/epubgrep-0.5.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/app-text/epubgrep/Manifest b/app-text/epubgrep/Manifest
index 5a283250d..9ca543128 100644
--- a/app-text/epubgrep/Manifest
+++ b/app-text/epubgrep/Manifest
@@ -1,2 +1,3 @@
DIST epubgrep-0.3.2.tar.gz 241538 BLAKE2B 77de3e45ae79e957bf6ecaaccb55b1944b845894dce9ec2e6eb2f8440d0e90a6ee4185824a04435351726d72ea4cacef2d63d14265ae1f9c952d6ad341126533 SHA512 ea9eb953a05cfa1cb9cf54d27341d1b0af6fb95835495d975405e43c7c01d6c74e69f20e36aaf4ac238e55f9cf0ede7ecb42822d717b40e068e7a6aaef798ec3
DIST epubgrep-0.4.0.tar.gz 247541 BLAKE2B f193ea359edc56343cfaab85b33c52f1fda832e335b58a7d2f6d6b98538870e043d6a1b56e8e3f562bd2dff8ddd809aeacad88bf047b2a6e7933a68b29312f49 SHA512 ae6005b62c8fc0ce8d3ae00fb4c04b2f6d84aca4c3497722be52c064b4403a15bc30aa33b4f59bc834d0501bee984f4df1c4a5c620ad14f83186776c46a73fa5
+DIST epubgrep-0.5.0.tar.gz 253335 BLAKE2B 43a0fff1368a4173797355b8e408ea740ec2810fc13d2a96fb96fda861d076b28c2ce1ce66ddeea64370be21f0873327a96bddca249c73427f6874476dd1d628 SHA512 87deba97675f827dd7e8914b7cf537d903f22a91504e0316e70fd04e567e0282998c729d1a7cef0d0bfaaaa8cf2bd4765afa18c41403248f261bc4240dd08c1a
diff --git a/app-text/epubgrep/epubgrep-0.5.0.ebuild b/app-text/epubgrep/epubgrep-0.5.0.ebuild
new file mode 100644
index 000000000..35dd9fa50
--- /dev/null
+++ b/app-text/epubgrep/epubgrep-0.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Search tool for EPUB e-books"
+HOMEPAGE="https://schlomp.space/tastytea/epubgrep"
+SRC_URI="https://schlomp.space/tastytea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boost[nls]
+ app-arch/libarchive[bzip2,iconv,lzma,zlib]
+ dev-libs/libfmt
+ dev-libs/pugixml
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/termcolor
+ dev-cpp/nlohmann_json
+ test? ( dev-cpp/catch )
+"
+BDEPEND="
+ sys-devel/gettext
+ app-text/asciidoc
+"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DWITH_TESTS=$(usex test)"
+ "-DFALLBACK_BUNDLED=NO"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ BUILD_DIR="${BUILD_DIR}/tests" cmake_src_test
+}