aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-05-30 14:10:58 +0200
committerRonny (tastytea) Gutbrod <gentoo@tastytea.de>2021-05-30 14:17:04 +0200
commit587c3d2eea48874b9050e6788fb71b7cab9bd03b (patch)
treead8d4bca90f5ba76c5c84049bdd577e46157564d /app-text
parentx11-misc/betterlockscreen: version bump to 3.2.0 (diff)
downloadguru-587c3d2eea48874b9050e6788fb71b7cab9bd03b.tar.gz
guru-587c3d2eea48874b9050e6788fb71b7cab9bd03b.tar.bz2
guru-587c3d2eea48874b9050e6788fb71b7cab9bd03b.zip
app-text/epubgrep: Version bump 0.4.0.
Signed-off-by: Ronny (tastytea) Gutbrod <gentoo@tastytea.de>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/epubgrep/Manifest1
-rw-r--r--app-text/epubgrep/epubgrep-0.4.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/app-text/epubgrep/Manifest b/app-text/epubgrep/Manifest
index abc924d1a..fa0f3a4fc 100644
--- a/app-text/epubgrep/Manifest
+++ b/app-text/epubgrep/Manifest
@@ -1,2 +1,3 @@
DIST epubgrep-0.3.1.tar.gz 221043 BLAKE2B 26c7cd1bfa366cdfdd8c4c271cfefa893866db84769edd900dbec6bc543fad6ce18ebeadd7c4c652322adc9152a93911cf649632a9c2668eb53cd8742cc54259 SHA512 1846b9a5b0c3f92d0194a832bc3f560eaae95b811b2def5a38d1346cac5e84534116d9bc27d7d0925a8fe73722326d7000e7cea9318fdcd899bc808358719be7
DIST epubgrep-0.3.2.tar.gz 241538 BLAKE2B 77de3e45ae79e957bf6ecaaccb55b1944b845894dce9ec2e6eb2f8440d0e90a6ee4185824a04435351726d72ea4cacef2d63d14265ae1f9c952d6ad341126533 SHA512 ea9eb953a05cfa1cb9cf54d27341d1b0af6fb95835495d975405e43c7c01d6c74e69f20e36aaf4ac238e55f9cf0ede7ecb42822d717b40e068e7a6aaef798ec3
+DIST epubgrep-0.4.0.tar.gz 247541 BLAKE2B f193ea359edc56343cfaab85b33c52f1fda832e335b58a7d2f6d6b98538870e043d6a1b56e8e3f562bd2dff8ddd809aeacad88bf047b2a6e7933a68b29312f49 SHA512 ae6005b62c8fc0ce8d3ae00fb4c04b2f6d84aca4c3497722be52c064b4403a15bc30aa33b4f59bc834d0501bee984f4df1c4a5c620ad14f83186776c46a73fa5
diff --git a/app-text/epubgrep/epubgrep-0.4.0.ebuild b/app-text/epubgrep/epubgrep-0.4.0.ebuild
new file mode 100644
index 000000000..17ddaacde
--- /dev/null
+++ b/app-text/epubgrep/epubgrep-0.4.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Search tool for EPUB e-books"
+HOMEPAGE="https://schlomp.space/tastytea/epubgrep"
+SRC_URI="https://schlomp.space/tastytea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="AGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boost[nls]
+ app-arch/libarchive[bzip2,iconv,lzma,zlib]
+ dev-libs/libfmt
+ dev-libs/pugixml
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/termcolor
+ test? ( dev-cpp/catch )
+"
+BDEPEND="
+ sys-devel/gettext
+ app-text/asciidoc
+"
+
+src_configure() {
+ local mycmakeargs=(
+ "-DWITH_TESTS=$(usex test)"
+ "-DFALLBACK_BUNDLED=NO"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ BUILD_DIR="${BUILD_DIR}/tests" cmake_src_test
+}