aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon van der Maas <svdm-gentoo@protonmail.com>2021-02-20 14:11:13 +0100
committerSimon van der Maas <svdm-gentoo@protonmail.com>2021-02-20 14:11:22 +0100
commit2a7be35ff175a63a2dfb9587a2f76c2a17aef360 (patch)
treee6e3929427512b2f72d2a411a03b9573ab13d3b3 /app-shells/ohmyzsh
parentapp-emulation/dxvk-bin: Remove old ebuild. (diff)
downloadguru-2a7be35ff175a63a2dfb9587a2f76c2a17aef360.tar.gz
guru-2a7be35ff175a63a2dfb9587a2f76c2a17aef360.tar.bz2
guru-2a7be35ff175a63a2dfb9587a2f76c2a17aef360.zip
app-shells/ohmyzsh: new package
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Simon van der Maas <svdm-gentoo@protonmail.com>
Diffstat (limited to 'app-shells/ohmyzsh')
-rw-r--r--app-shells/ohmyzsh/Manifest1
-rw-r--r--app-shells/ohmyzsh/metadata.xml8
-rw-r--r--app-shells/ohmyzsh/ohmyzsh-0_pre20210209.ebuild33
-rw-r--r--app-shells/ohmyzsh/ohmyzsh-9999.ebuild33
4 files changed, 75 insertions, 0 deletions
diff --git a/app-shells/ohmyzsh/Manifest b/app-shells/ohmyzsh/Manifest
new file mode 100644
index 000000000..18908c527
--- /dev/null
+++ b/app-shells/ohmyzsh/Manifest
@@ -0,0 +1 @@
+DIST ohmyzsh-0_pre20210209.tar.gz 696345 BLAKE2B a51a47dfc655ab36d6b2d9d73726caee5d9fbb9130b071feb17440c3d04269f8f2129e9f343594315f3e1f01b1de865cdc9bbee63ba370723d88188903d5dba3 SHA512 c66c87fd767748c7849cd2c799246cc145cdabc3001ab76653794b9a73100fb412e84a006386be57bc603b9dd66d823d758ae31afc6bc0f9faea1e41f38d69f6
diff --git a/app-shells/ohmyzsh/metadata.xml b/app-shells/ohmyzsh/metadata.xml
new file mode 100644
index 000000000..ad8cead24
--- /dev/null
+++ b/app-shells/ohmyzsh/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>svdm-gentoo@protonmail.com</email>
+ <name>Simon van der Maas</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-shells/ohmyzsh/ohmyzsh-0_pre20210209.ebuild b/app-shells/ohmyzsh/ohmyzsh-0_pre20210209.ebuild
new file mode 100644
index 000000000..7187fd950
--- /dev/null
+++ b/app-shells/ohmyzsh/ohmyzsh-0_pre20210209.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ inherit git-r3
+else
+ MY_COMMIT="f21e646ce6c09198f7f625c597f08af49551fdb0"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${MY_COMMIT}"
+fi
+
+DESCRIPTION="A framework for managing your zsh configuration."
+HOMEPAGE="https://ohmyz.sh"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="app-shells/zsh"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/zsh/site-contrib/oh-my-zsh"
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "In order to use ${PN}, copy /usr/share/zsh/site-contrib/oh-my-zsh/templates/zshrc.zsh-template over to your ~/.zshrc"
+ elog "and change the path of your oh-my-zsh installation to: 'export ZSH=/usr/share/zsh/site-contrib/oh-my-zsh'"
+}
diff --git a/app-shells/ohmyzsh/ohmyzsh-9999.ebuild b/app-shells/ohmyzsh/ohmyzsh-9999.ebuild
new file mode 100644
index 000000000..7187fd950
--- /dev/null
+++ b/app-shells/ohmyzsh/ohmyzsh-9999.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
+ inherit git-r3
+else
+ MY_COMMIT="f21e646ce6c09198f7f625c597f08af49551fdb0"
+ SRC_URI="https://github.com/${PN}/${PN}/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${MY_COMMIT}"
+fi
+
+DESCRIPTION="A framework for managing your zsh configuration."
+HOMEPAGE="https://ohmyz.sh"
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="app-shells/zsh"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto "/usr/share/zsh/site-contrib/oh-my-zsh"
+ doins -r *
+}
+
+pkg_postinst() {
+ elog "In order to use ${PN}, copy /usr/share/zsh/site-contrib/oh-my-zsh/templates/zshrc.zsh-template over to your ~/.zshrc"
+ elog "and change the path of your oh-my-zsh installation to: 'export ZSH=/usr/share/zsh/site-contrib/oh-my-zsh'"
+}