aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Reva <denis7774@gmail.com>2024-11-16 22:13:00 +0500
committerDenis Reva <denis7774@gmail.com>2024-11-16 22:13:00 +0500
commit9e5c8f242c3b55e1395dad9c8d38b9e912231ab8 (patch)
tree17179f2799af8ec869b7108fcc93f3dabee4e02a /app-containers
parentdev-python/rich-click: add 1.8.4 (diff)
downloadguru-9e5c8f242c3b55e1395dad9c8d38b9e912231ab8.tar.gz
guru-9e5c8f242c3b55e1395dad9c8d38b9e912231ab8.tar.bz2
guru-9e5c8f242c3b55e1395dad9c8d38b9e912231ab8.zip
app-containers/waydroid: drop 1.4.2, 1.4.2-r1, 1.4.2-r2
Signed-off-by: Denis Reva <denis7774@gmail.com>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/waydroid/Manifest1
-rw-r--r--app-containers/waydroid/waydroid-1.4.2-r1.ebuild91
-rw-r--r--app-containers/waydroid/waydroid-1.4.2-r2.ebuild96
-rw-r--r--app-containers/waydroid/waydroid-1.4.2.ebuild87
4 files changed, 0 insertions, 275 deletions
diff --git a/app-containers/waydroid/Manifest b/app-containers/waydroid/Manifest
index 867d00d69..0b7266e24 100644
--- a/app-containers/waydroid/Manifest
+++ b/app-containers/waydroid/Manifest
@@ -1,2 +1 @@
-DIST waydroid-1.4.2.tar.gz 242536 BLAKE2B 77a6ba3a00bc2c95f767bec9ec93d1e4dcd3e20cf39d8c3ce0dea00f6c1c2a1eb6399f2ef0d8017958584205d067646d0e50d0f865c954284b7384f4a492a084 SHA512 0d3eba799895c853545b7087e3c07160d593d4a3166822039973669bc0ee93a8a6b9c394a7d982e57cfbbfbd8df1ba7991dd33b1b1517d79fcbe191d8a86890a
DIST waydroid-1.4.3.tar.gz 240785 BLAKE2B e654f2ed74f8d22810417ee5d6f6134ee5050b4e105dd2c643fa39df660e8c325a80f8e75176dd65e052deba187890f8afd94c384d707e0287027d3454a533ea SHA512 e94edeca7097cb1572296d0b6e308483b1bd21e1bd50d9e6d2bd54d4ba75ffeb8bd4e1d1f8143fbcf49dddd30155da2e3c5a58240a85b159dae4e71985e547aa
diff --git a/app-containers/waydroid/waydroid-1.4.2-r1.ebuild b/app-containers/waydroid/waydroid-1.4.2-r1.ebuild
deleted file mode 100644
index 83aa5c2c2..000000000
--- a/app-containers/waydroid/waydroid-1.4.2-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit linux-info xdg python-single-r1
-
-DESCRIPTION="Container-based approach to boot a full Android system on Linux systems"
-HOMEPAGE="https://waydro.id"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-IUSE="apparmor +clipboard systemd"
-
-DEPEND="|| ( virtual/linux-sources virtual/dist-kernel )"
-RDEPEND="
- systemd? ( sys-apps/systemd )
- app-containers/lxc[systemd?,apparmor?,seccomp]
- $(python_gen_cond_dep '
- clipboard? ( >=dev-python/pyclip-0.7.0[wayland,${PYTHON_USEDEP}] )
- dev-python/pygobject[${PYTHON_USEDEP}]
- >=dev-python/gbinder-1.1.1[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- ')
- net-firewall/nftables
- net-dns/dnsmasq
- >=dev-libs/libglibutil-1.0.67
- >=dev-libs/gbinder-1.1.21
- ${PYTHON_DEPS}
-"
-
-CONFIG_CHECK="
- ~ANDROID_BINDER_IPC
- ~ANDROID_BINDERFS
- ~MEMFD_CREATE
-"
-ERROR_ANDROID_BINDERFS="CONFIG_ANDROID_BINDERFS: need for creating Android-specific binder IPC channels"
-ERROR_ANDROID_BINDER_IPC="CONFIG_ANDROID_BINDER_IPC: need for creating Android-specific binder IPC channels"
-ERROR_MEMFD_CREATE="CONFIG_MEMFD_CREATE: it completely replaced deprecated ISHMEM drivers,
- therefore it's vital for android-specific memory management"
-
-pkg_setup() {
- linux-info_pkg_setup
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- if ! use apparmor; then
- # https://github.com/waydroid/waydroid/issues/652
- sed -e '/^lxc\.apparmor\.profile =/d' \
- -i data/configs/config_3 || die
- fi
- default
-}
-
-src_install() {
- python_fix_shebang waydroid.py
- emake install DESTDIR="${D}" USE_NFTABLES=1 USE_SYSTEMD=$(usex systemd 1 0)
- if ! use systemd; then
- elog "Installing waydroid OpenRC daemon"
- doinitd "${FILESDIR}"/waydroid
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- elog "After package installation run either 'emerge --config app-containers/waydroid'"
- elog "or 'waydroid init' from root shell to install android container runtime"
- elog "To run waydroid, 1. Start container: 'rc-service waydroid start'"
- elog "2. start wayland channel (from user shell) 'waydroid session start'"
- elog "Contact https://docs.waydro.id/usage/install-on-desktops for how-to guides"
- elog "(does not cover Gentoo-specific things sadly)"
- elog
-
- ewarn "Make sure you have NFTABLES up and running in your kernel. See"
- ewarn "https://wiki.gentoo.org/wiki/Nftables for how-to details"
- ewarn
-
- if use apparmor; then
- ewarn "Apparmor support has not been tested by package maintainer yet"
- fi
-}
-
-pkg_config() {
- "${EROOT}"/usr/bin/waydroid init
-}
diff --git a/app-containers/waydroid/waydroid-1.4.2-r2.ebuild b/app-containers/waydroid/waydroid-1.4.2-r2.ebuild
deleted file mode 100644
index 89c34aaa8..000000000
--- a/app-containers/waydroid/waydroid-1.4.2-r2.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit linux-info xdg python-single-r1
-
-DESCRIPTION="Container-based approach to boot a full Android system on Linux systems"
-HOMEPAGE="https://waydro.id"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-IUSE="apparmor +clipboard systemd"
-
-DEPEND="|| ( virtual/linux-sources virtual/dist-kernel )"
-RDEPEND="
- systemd? ( sys-apps/systemd )
- app-containers/lxc[systemd?,apparmor?,seccomp]
- $(python_gen_cond_dep '
- clipboard? ( >=dev-python/pyclip-0.7.0[wayland,${PYTHON_USEDEP}] )
- dev-python/pygobject[${PYTHON_USEDEP}]
- >=dev-python/gbinder-1.1.1[${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- ')
- net-firewall/nftables
- net-dns/dnsmasq
- >=dev-libs/libglibutil-1.0.67
- >=dev-libs/gbinder-1.1.21
- ${PYTHON_DEPS}
-"
-
-CONFIG_CHECK="
- ~ANDROID_BINDER_IPC
- ~ANDROID_BINDERFS
- ~MEMFD_CREATE
- ~NETFILTER_XT_TARGET_MASQUERADE
- ~NETFILTER_XT_NAT
-"
-ERROR_ANDROID_BINDERFS="CONFIG_ANDROID_BINDERFS: need for creating Android-specific binder IPC channels"
-ERROR_ANDROID_BINDER_IPC="CONFIG_ANDROID_BINDER_IPC: need for creating Android-specific binder IPC channels"
-ERROR_MEMFD_CREATE="CONFIG_MEMFD_CREATE: it completely replaced deprecated ISHMEM drivers,
- therefore it's vital for android-specific memory management"
-ERROR_NETFILTER_XT_NAT="CONFIG_NETFILTER_XT_NAT: see bug #937106"
-ERROR_NETFILTER_XT_TARGET_MASQUERADE="CONFIG_NETFILTER_XT_TARGET_MASQUERADE: see bug #937106"
-
-
-pkg_setup() {
- linux-info_pkg_setup
- python-single-r1_pkg_setup
-}
-
-src_prepare() {
- if ! use apparmor; then
- # https://github.com/waydroid/waydroid/issues/652
- sed -e '/^lxc\.apparmor\.profile =/d' \
- -i data/configs/config_3 || die
- fi
- default
-}
-
-src_install() {
- python_fix_shebang waydroid.py
- emake install DESTDIR="${D}" USE_NFTABLES=1 USE_SYSTEMD=$(usex systemd 1 0)
- if ! use systemd; then
- elog "Installing waydroid OpenRC daemon"
- doinitd "${FILESDIR}"/waydroid
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- elog "After package installation run either 'emerge --config app-containers/waydroid'"
- elog "or 'waydroid init' from root shell to install android container runtime"
- elog "To run waydroid, 1. Start container: 'rc-service waydroid start'"
- elog "2. start wayland channel (from user shell) 'waydroid session start'"
- elog "Contact https://docs.waydro.id/usage/install-on-desktops for how-to guides"
- elog "(does not cover Gentoo-specific things sadly)"
- elog
-
- ewarn "Make sure you have NFTABLES up and running in your kernel. See"
- ewarn "https://wiki.gentoo.org/wiki/Nftables for how-to details"
- ewarn
-
- if use apparmor; then
- ewarn "Apparmor support has not been tested by package maintainer yet"
- fi
-}
-
-pkg_config() {
- "${EROOT}"/usr/bin/waydroid init
-}
diff --git a/app-containers/waydroid/waydroid-1.4.2.ebuild b/app-containers/waydroid/waydroid-1.4.2.ebuild
deleted file mode 100644
index 10bd38daf..000000000
--- a/app-containers/waydroid/waydroid-1.4.2.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-inherit linux-info xdg python-single-r1
-
-DESCRIPTION="Container-based approach to boot a full Android system on Linux systems"
-HOMEPAGE="https://waydro.id"
-SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-IUSE="systemd apparmor"
-
-DEPEND="|| ( virtual/linux-sources virtual/dist-kernel )"
-RDEPEND="
- systemd? ( sys-apps/systemd )
- app-containers/lxc[systemd?,apparmor?,seccomp]
- $(python_gen_cond_dep '
- dev-python/pygobject[${PYTHON_USEDEP}]
- >=dev-python/gbinder-1.1.1[${PYTHON_USEDEP}]
- >=dev-python/pyclip-0.7.0[wayland,${PYTHON_USEDEP}]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- ')
- net-firewall/nftables
- net-dns/dnsmasq
- >=dev-libs/libglibutil-1.0.67
- >=dev-libs/gbinder-1.1.21
- ${PYTHON_DEPS}
-"
-
-CONFIG_CHECK="
- ~ANDROID_BINDER_IPC
- ~ANDROID_BINDERFS
- ~MEMFD_CREATE
-"
-ERROR_ANDROID_BINDERFS="CONFIG_ANDROID_BINDERFS: need for creating Android-specific binder IPC channels"
-ERROR_ANDROID_BINDER_IPC="CONFIG_ANDROID_BINDER_IPC: need for creating Android-specific binder IPC channels"
-ERROR_MEMFD_CREATE="CONFIG_MEMFD_CREATE: it completely replaced deprecated ISHMEM drivers,
- therefore it's vital for android-specific memory management"
-
-src_compile() {
- :
-}
-
-src_install() {
- python_fix_shebang waydroid.py
- emake install DESTDIR="${D}" USE_NFTABLES=1 USE_SYSTEMD=$(usex systemd 1 0)
- if ! use systemd; then
- elog "Installing waydroid OpenRC daemon"
- doinitd "${FILESDIR}"/waydroid
- fi
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- elog "After package installation run either 'emerge --config app-containers/waydroid'"
- elog "or 'waydroid init' from root shell to install android container runtime"
- elog "To run waydroid, 1. Start container: 'rc-service waydroid start'"
- elog "2. start wayland channel (from user shell) 'waydroid session start'"
- elog "Contact https://docs.waydro.id/usage/install-on-desktops for how-to guides"
- elog "(does not cover Gentoo-specific things sadly)"
- elog
-
- ewarn "Make sure you have NFTABLES up and running in your kernel. See"
- ewarn "https://wiki.gentoo.org/wiki/Nftables for how-to details"
- ewarn
-
- if ! use apparmor; then
- ewarn "If you use app-containers/lxc without apparmor, make sure you deleted or commented out in waydroid LXC config"
- ewarn "(generated after waydroid init) in /var/lib/waydroid/lxc/waydroid/config the following string:"
- ewarn "lxc.apparmor.profile = unconfined"
- ewarn "or waydroid experiences crash during launch"
- ewarn "See also https://github.com/waydroid/waydroid/issues/652"
- else
- ewarn "Apparmor support has not been tested by package maintainer yet"
- fi
-}
-
-pkg_config() {
- "${EROOT}"/usr/bin/waydroid init
-}