aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2022-07-14 21:50:47 -0400
committerWolfgang E. Sanyer <ezzieyguywuf@gmail.com>2022-07-14 23:11:23 -0400
commit28c6c103f91472e29bd9b1fba9399049eee6aead (patch)
tree46e415f176e1e5bd9117ff2b554da9e136ca4e65 /app-backup
parentdev-python/rst2ansi: add python 3.10 to PYTHON_COMPAT (diff)
downloadguru-28c6c103f91472e29bd9b1fba9399049eee6aead.tar.gz
guru-28c6c103f91472e29bd9b1fba9399049eee6aead.tar.bz2
guru-28c6c103f91472e29bd9b1fba9399049eee6aead.zip
app-backup/b2: bump to 3.4.0
Signed-off-by: Wolfgang E. Sanyer <ezzieyguywuf@gmail.com>
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/b2/Manifest1
-rw-r--r--app-backup/b2/b2-3.4.0.ebuild55
-rw-r--r--app-backup/b2/files/b2-3.4.0-disable-pip-requirement-installs.patch24
3 files changed, 80 insertions, 0 deletions
diff --git a/app-backup/b2/Manifest b/app-backup/b2/Manifest
index 9e0338705..01eedbe3e 100644
--- a/app-backup/b2/Manifest
+++ b/app-backup/b2/Manifest
@@ -1,2 +1,3 @@
DIST b2-2.5.0.tar.gz 72245 BLAKE2B 321114925d594af631a2d489b46a45d35113f561c19223ba62a2777c3c4d578a5ec494c86f35ea4574f81c569de18eba1622a0a8af83379a61ac1341f9050597 SHA512 f9377bd1bbc61d4297afc4080173695df7d3f8461ba0b3c47c408e5cdfd195542a81a4110316d132dab69a90ab6e0a9bf2b08b7b2e4317d29ce8e49d327819ca
DIST b2-3.0.3.tar.gz 78692 BLAKE2B b216b40e7d3bb0a7b5564418ea463bf9e143a0f1a1408ebe2312869943e5bfbae175afa75aadbe203c05b71026f0fc8fa8f6031b7c3a636ba9b9b6017e2e17be SHA512 61ef1dd1d406f04b50b0d8bb3df921127d996465d53f00dc4cf77d5b6e63ce15fdb9a2d1fc5d7d1c01e734c93fe3e4fe316ca43f420aa6c31f7e3d88e134b659
+DIST b2-3.4.0.tar.gz 86706 BLAKE2B 2aa1f4934db0bcf8c1334a5def94fd74824a9ca19d293b201b29f8c4511e8d423fd77d71734c386aeb41e60747ea71d36d8c049676cf6fcd3e101354440da8cc SHA512 5b0f411301f9b022c066ab3a1170d2ef3b21a76fe9c4e668d1da0cbd07334d11614f93d283e5c0482cb4f6985466d28b0fe59b4c058a87643218dd7a96857418
diff --git a/app-backup/b2/b2-3.4.0.ebuild b/app-backup/b2/b2-3.4.0.ebuild
new file mode 100644
index 000000000..9e7054846
--- /dev/null
+++ b/app-backup/b2/b2-3.4.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Command-line tool for BackBlaze's B2 product"
+HOMEPAGE="https://github.com/Backblaze/B2_Command_Line_Tool"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.5.0-nameclash.patch"
+ "${FILESDIR}/${PN}-3.4.0-disable-pip-requirement-installs.patch"
+)
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ >=dev-python/arrow-1.0.2[${PYTHON_USEDEP}]
+ >=dev-python/b2sdk-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/docutils-0.16[${PYTHON_USEDEP}]
+ >=dev-python/phx-class-registry-3.0.5[${PYTHON_USEDEP}]
+ >=dev-python/rst2ansi-0.1.5[${PYTHON_USEDEP}]
+ ')
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-3.3.0[${PYTHON_USEDEP}]
+ ' pypy3 python3_8)
+"
+
+distutils_enable_tests pytest
+
+# - integration tests require an application key and id (which is # reasonable)
+# - sync tests require network access
+# - Per https://github.com/Backblaze/B2_Command_Line_Tool/issues/687 , the
+# parse_millis test is broken due to an upstream issue
+python_test() {
+ epytest \
+ --deselect test/integration/test_b2_command_line.py::test_integration \
+ --deselect test/unit/test_console_tool.py::TestConsoleTool::test_sync_exclude_if_modified_after_exact \
+ --deselect test/unit/test_console_tool.py::TestConsoleTool::test_sync_exclude_if_modified_after_in_range \
+ --deselect test/unit/test_arg_parser.py::TestCustomArgTypes::test_parse_millis_from_float_timestamp
+}
+
+pkg_postinst() {
+ elog "The b2 executable has been renamed to backblaze2 in order to"
+ elog "avoid a name clash with b2 from boost-build"
+}
diff --git a/app-backup/b2/files/b2-3.4.0-disable-pip-requirement-installs.patch b/app-backup/b2/files/b2-3.4.0-disable-pip-requirement-installs.patch
new file mode 100644
index 000000000..389485167
--- /dev/null
+++ b/app-backup/b2/files/b2-3.4.0-disable-pip-requirement-installs.patch
@@ -0,0 +1,24 @@
+# These configurations attempt to install missing dependencies using pip, which
+# violates the network sandbox. Instead, we'll manage the dependencies in
+# portage.
+--- a/setup.py
++++ b/setup.py
+@@ -104,7 +104,7 @@ setup(
+ # requirements files see:
+ # https://packaging.python.org/en/latest/requirements.html
+ dependency_links=[],
+- install_requires=read_requirements(),
++ # install_requires=read_requirements(),
+
+ # List additional groups of dependencies here (e.g. development
+ # dependencies). You can install these using the following syntax,
+@@ -110,7 +110,7 @@ setup(
+ # dependencies). You can install these using the following syntax,
+ # for example:
+ # $ pip install -e .[dev,test]
+ extras_require={'doc': read_requirements('doc')},
+- setup_requires=['setuptools_scm<6.0'],
++ # setup_requires=['setuptools_scm<6.0'],
+ use_scm_version=True,
+
+ # If there are data files included in your packages that need to be