aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Postiglione <andrea.postiglione@gmail.com>2021-10-29 18:49:06 +0200
committerAndrea Postiglione <andrea.postiglione@gmail.com>2021-10-29 18:49:06 +0200
commit0229c0e4fea011b9433a66710e68f96ad5d3ee23 (patch)
tree1bad80042635ad927ee891b7961c02727c4061ef /app-admin
parentapp-admin/awscli-bin: add 2.3.2 (diff)
downloadguru-0229c0e4fea011b9433a66710e68f96ad5d3ee23.tar.gz
guru-0229c0e4fea011b9433a66710e68f96ad5d3ee23.tar.bz2
guru-0229c0e4fea011b9433a66710e68f96ad5d3ee23.zip
app-admin/customrescuecd-x86_64: version bump to 0.12.3
Signed-off-by: Andrea Postiglione <andrea.postiglione@gmail.com>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/customrescuecd-x86_64/Manifest2
-rw-r--r--app-admin/customrescuecd-x86_64/customrescuecd-x86_64-0.12.3.ebuild55
2 files changed, 56 insertions, 1 deletions
diff --git a/app-admin/customrescuecd-x86_64/Manifest b/app-admin/customrescuecd-x86_64/Manifest
index 4fa64e256..62803dab4 100644
--- a/app-admin/customrescuecd-x86_64/Manifest
+++ b/app-admin/customrescuecd-x86_64/Manifest
@@ -1 +1 @@
-DIST CUSTOMRESCUECD-x86_64-0.12.2.iso 1516290048 BLAKE2B c9d2b857948c09a16b86bb9ccb7373f1908f52f97ed21c64ef422e6d7c3501278fd7871b34c035a70554b494926325d1be2978df729ffd93cb7f3bee6b0c5adc SHA512 f215116878557ada9d321ba018970723a1e3905cbebf12aac5e1e65e97c9180f852fcfff5c2133c28e97bb3d1eb8fb80ca26bbf307de8b202fa39eb02a474abd
+DIST CUSTOMRESCUECD-x86_64-0.12.3.iso 1531445248 BLAKE2B a4873c26660cebb9f12b70df9aba0fef8dc64d2e15184f8054d252c3f893c967dcbc00b6b5cc154e726379c6a8cf6d024e432eba41de35a5488715f9a1ddb877 SHA512 fa2d535918f1bc321f65ae111b806c91aa34e09d32907fc1c12ee186b2ed4e96494d0c555101fe3d969f3364b95bae5496ff8a2ed6b350f6321b8f084cac6192
diff --git a/app-admin/customrescuecd-x86_64/customrescuecd-x86_64-0.12.3.ebuild b/app-admin/customrescuecd-x86_64/customrescuecd-x86_64-0.12.3.ebuild
new file mode 100644
index 000000000..d57a8059d
--- /dev/null
+++ b/app-admin/customrescuecd-x86_64/customrescuecd-x86_64-0.12.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P="CUSTOMRESCUECD-x86_64"
+DESCRIPTION="A system rescue cd or usbstick for desktop and server based on gentoo"
+HOMEPAGE="https://sourceforge.net/projects/customrescuecd"
+SRC_URI="mirror://sourceforge/customrescuecd/"${MY_P}"-"${PV}".iso"
+
+LICENSE="GPL-3"
+SLOT="${PV}"
+KEYWORDS="~amd64"
+RESTRICT="bindist mirror"
+
+S=${WORKDIR}
+
+src_unpack() { :; }
+
+src_install() {
+ insinto "/usr/share/${PN%-*}"
+ doins "${DISTDIR}/${MY_P}-${PV}.iso"
+}
+
+pkg_postinst() {
+ local f=${EROOT}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # no version newer than ours? we're the newest!
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ ln -f -s -v "${MY_P}-${PV}.iso" "${f}" || die
+ fi
+}
+
+pkg_postrm() {
+ local f=${EROOT}/usr/share/${PN%-*}/${PN}-newest.iso
+
+ # if there is no version newer than ours installed
+ if ! has_version ">${CATEGORY}/${PF}"; then
+ # and we are truly and completely uninstalled...
+ if [[ ! ${REPLACED_BY_VERSION} ]]; then
+ # then find an older version to set the symlink to
+ local newest_version=$(best_version "<${CATEGORY}/${PF}")
+
+ if [[ ${newest_version} ]]; then
+ # update the symlink
+ ln -f -s -v "${newest_version%-r*}.iso" "${f}" || die
+ else
+ # last version removed? clean up the symlink
+ rm -v "${f}" || die
+ # and the parent directory
+ rmdir "${f%/*}" || die
+ fi
+ fi
+ fi
+}