aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna Vyalkova <cyber@sysrq.in>2021-05-04 01:31:32 +0500
committerAnna Vyalkova <cyber@sysrq.in>2021-05-04 04:27:25 +0500
commitc5f334f70b5a09646d02f587b5d01c87c7cdfc07 (patch)
treea8ce42cbafe921b1dc7957de5d26e1513179202a
parentdev-python/sphinxcontrib-trio: disable failing test (diff)
downloadguru-c5f334f70b5a09646d02f587b5d01c87c7cdfc07.tar.gz
guru-c5f334f70b5a09646d02f587b5d01c87c7cdfc07.tar.bz2
guru-c5f334f70b5a09646d02f587b5d01c87c7cdfc07.zip
dev-python/aspectlib: disable failing test
Closes: https://bugs.gentoo.org/784011 Signed-off-by: Anna Vyalkova <cyber@sysrq.in>
-rw-r--r--dev-python/aspectlib/aspectlib-1.5.2.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/aspectlib/aspectlib-1.5.2.ebuild b/dev-python/aspectlib/aspectlib-1.5.2.ebuild
index 5290da079..720bed235 100644
--- a/dev-python/aspectlib/aspectlib-1.5.2.ebuild
+++ b/dev-python/aspectlib/aspectlib-1.5.2.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
+DISTUTILS_USE_SETUPTOOLS=bdepend
inherit distutils-r1
@@ -29,7 +29,6 @@ DEPEND="
dev-python/mock[${PYTHON_USEDEP}]
dev-python/nose[${PYTHON_USEDEP}]
dev-python/process-tests[${PYTHON_USEDEP}]
- www-servers/tornado[${PYTHON_USEDEP}]
)
"
@@ -37,3 +36,9 @@ S="${WORKDIR}/python-${P}"
distutils_enable_tests pytest
distutils_enable_sphinx docs dev-python/sphinx-py3doc-enhanced-theme
+
+python_test() {
+ # Test fails with tornado>=6
+ # https://github.com/ionelmc/python-aspectlib/issues/15
+ epytest --deselect tests/test_integrations_py3.py::test_decorate_tornado_coroutine
+}