summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'grub2-themes/ask-larry/ask-larry-0.2.0.ebuild')
-rw-r--r--grub2-themes/ask-larry/ask-larry-0.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/grub2-themes/ask-larry/ask-larry-0.2.0.ebuild b/grub2-themes/ask-larry/ask-larry-0.2.0.ebuild
new file mode 100644
index 0000000..47ec700
--- /dev/null
+++ b/grub2-themes/ask-larry/ask-larry-0.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="5"
+
+inherit grub2-theme
+
+DESCRIPTION="Grub2 GFX theme ask-larry"
+HOMEPAGE="https://github.com/vitalogy/grub2-theme-ask-larry"
+SRC_URI="https://github.com/vitalogy/grub2-theme-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT BitstreamVera ArevFonts public-domain CC0-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="widescreen"
+
+S="${WORKDIR}"/grub2-theme-${PN}-${PV}
+
+RESTRICT="bindist mirror"
+
+src_prepare() {
+ rm -r screenshot || die
+}
+
+src_install() {
+ insinto "${GRUB2_THEME_DIR}/${PN}"
+ doins -r .
+ if use widescreen ; then
+ dosym theme_widescreen.txt ${GRUB2_THEME_DIR}/${PN}/theme.txt
+ else
+ dosym theme_normal.txt ${GRUB2_THEME_DIR}/${PN}/theme.txt
+ fi
+}