aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGergely Nagy <ngg@tresorit.com>2019-12-14 13:56:41 +0100
committerMikhail Pukhlikov <cynede@gentoo.org>2019-12-16 11:22:39 +0400
commit2da44cb6659f691d41ec5021f06c8e9702c509c1 (patch)
treeb71d71e5e393af8a9e2998b23c3e6484fba09529 /app-shells
parentapp-shells/pwsh-bin: add dependencies (diff)
downloaddotnet-2da44cb6659f691d41ec5021f06c8e9702c509c1.tar.gz
dotnet-2da44cb6659f691d41ec5021f06c8e9702c509c1.tar.bz2
dotnet-2da44cb6659f691d41ec5021f06c8e9702c509c1.zip
app-shells/pwsh-bin: add 7.0.0-preview.6
Signed-off-by: Gergely Nagy <ngg@tresorit.com> Closes: https://github.com/gentoo/dotnet/pull/457 Signed-off-by: Mikhail Pukhlikov <cynede@gentoo.org>
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/pwsh-bin/Manifest1
-rw-r--r--app-shells/pwsh-bin/pwsh-bin-7.0.0_pre6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/app-shells/pwsh-bin/Manifest b/app-shells/pwsh-bin/Manifest
index bb25990..d4ba397 100644
--- a/app-shells/pwsh-bin/Manifest
+++ b/app-shells/pwsh-bin/Manifest
@@ -1 +1,2 @@
DIST powershell-6.2.3-linux-x64.tar.gz 57418788 SHA256 48d7d33bd63f10d06ecd68f2efc9c07b5eca1ab1e492d08b586918c09a85105e SHA512 a8b80f8381ae75d55dc306ae1cf7488f82020ac5ac9baaade5d5878fda584b1f300dd0a868b3cada2a8d3cda14e37c0a218792bfae3906df09558db9045f3834 WHIRLPOOL 5a063dc0ce3c20761c0a8319999115253d380419a71c453a018039dd4e3a4c75d1dec38aaf2fae7c2b0499eba32187a011ff18cf8e194923e5c3208fbee44e14
+DIST powershell-7.0.0-preview.6-linux-x64.tar.gz 58048850 SHA256 9726f2177f61bde83fc2d1f8f346b9c80f65b83157e5682d12db7490abb476dc SHA512 628493cc34ed420119fa4632c11224afcd8694fe8b1e60b870643e795d7b569eb49247f728869363daacd023071c282918a3f08700c2ad04c5fb9c336930c44b WHIRLPOOL 4c033d2979687d3bc02cec74ed2f0e0363df6e6297dc40756350c515ccaf246b022254ee80819601529bb3772f66db1b630b021614ca3c6daafc44272e4d7ff5
diff --git a/app-shells/pwsh-bin/pwsh-bin-7.0.0_pre6.ebuild b/app-shells/pwsh-bin/pwsh-bin-7.0.0_pre6.ebuild
new file mode 100644
index 0000000..fe63479
--- /dev/null
+++ b/app-shells/pwsh-bin/pwsh-bin-7.0.0_pre6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="PowerShell - binary precompiled for glibc"
+HOMEPAGE="https://powershell.org/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://github.com/PowerShell/PowerShell/releases/download/v7.0.0-preview.6/powershell-7.0.0-preview.6-linux-x64.tar.gz )
+"
+
+SLOT="0"
+KEYWORDS=""
+
+QA_PREBUILT="*"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ >=sys-apps/lsb-release-1.4
+ >=sys-libs/libunwind-1.1-r1
+ >=dev-libs/icu-57.1
+ >=dev-util/lttng-ust-2.8.1
+ || ( dev-libs/openssl-compat:1.0.0 =dev-libs/openssl-1.0*:0 )
+ >=net-misc/curl-7.49.0
+ >=app-crypt/mit-krb5-1.14.2
+ >=sys-libs/zlib-1.2.8-r1"
+BDEPEND=""
+
+S=${WORKDIR}
+
+src_install() {
+ local dest="opt/pwsh"
+ dodir "${dest}"
+ local ddest="${D}/${dest}"
+ cp -a "${S}"/* "${ddest}/" || die
+ fperms 0755 "/${dest}/pwsh"
+ dosym "/${dest}/pwsh" "/usr/bin/pwsh"
+}