aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <stephen.arnold42@gmail.com>2015-12-03 12:39:38 -0800
committerSteve Arnold <stephen.arnold42@gmail.com>2015-12-03 12:39:38 -0800
commit92fe41e1ac52356d86475cfbf32efe6070457e98 (patch)
tree23da1b42b569d9773ab15477dfe2668ad0cd3d35 /sys-devel
parentdev-libs/elfutils: add workaround for arm-specific part of bug 500254 (diff)
downloadarm-92fe41e1ac52356d86475cfbf32efe6070457e98.tar.gz
arm-92fe41e1ac52356d86475cfbf32efe6070457e98.tar.bz2
arm-92fe41e1ac52356d86475cfbf32efe6070457e98.zip
sys-devel/binutils: add mapfile attribute patch for arm (upstreamed in
trunk feb 2015)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/Manifest2
-rw-r--r--sys-devel/binutils/binutils-2.25.1-r1.ebuild15
-rw-r--r--sys-devel/binutils/files/binutils-2.25.1-do_print_to_mapfile.patch23
-rw-r--r--sys-devel/binutils/files/binutils-configure-LANG.patch65
4 files changed, 105 insertions, 0 deletions
diff --git a/sys-devel/binutils/Manifest b/sys-devel/binutils/Manifest
new file mode 100644
index 0000000..6dc0601
--- /dev/null
+++ b/sys-devel/binutils/Manifest
@@ -0,0 +1,2 @@
+DIST binutils-2.25.1-patches-1.1.tar.xz 18724 SHA256 3d4c0ab2d45d3a952f60246fa5a4353f057c03110130b50e3b2103bd49c345fa SHA512 209c55bf26b51d8c513b40abd2d95f687159c4e964a6c732924f277d04c97323c427fe452c63d5ec6962dcd8892d6d5d807ba88826739425bce6812a31f573dd WHIRLPOOL 2b650af352183d2b58abaee955b223606d63bd5f22a73360e79af1d3b575c5ea385f90be92348ec850534d96f7b6632b1e494f314ec1655eedc26108e849aab7
+DIST binutils-2.25.1.tar.bz2 24163561 SHA256 b5b14added7d78a8d1ca70b5cb75fef57ce2197264f4f5835326b0df22ac9f22 SHA512 0b36dda0e6d32cd25613c0e64b56b28312515c54d6a159efd3db9a86717f114ab0a0a1f69d08975084d55713ebaeab64e4085c9b3d1c3fa86712869f80eb954d WHIRLPOOL daa804331ee880296c2fe29fd9b8a52cc695629d4bbe0b9889d96ffc54d330f00fac3f3cb12b3aaf6b7505521ef499c53760912cd7c9bb54f2d5e288224bd1eb
diff --git a/sys-devel/binutils/binutils-2.25.1-r1.ebuild b/sys-devel/binutils/binutils-2.25.1-r1.ebuild
new file mode 100644
index 0000000..0e458df
--- /dev/null
+++ b/sys-devel/binutils/binutils-2.25.1-r1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+PATCHVER="1.1"
+ELF2FLT_VER=""
+inherit toolchain-binutils
+
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd -sparc-fbsd ~x86-fbsd"
+
+src_prepare() {
+ use arm && epatch "${FILESDIR}/${P}"-do_print_to_mapfile.patch
+}
diff --git a/sys-devel/binutils/files/binutils-2.25.1-do_print_to_mapfile.patch b/sys-devel/binutils/files/binutils-2.25.1-do_print_to_mapfile.patch
new file mode 100644
index 0000000..3f41903
--- /dev/null
+++ b/sys-devel/binutils/files/binutils-2.25.1-do_print_to_mapfile.patch
@@ -0,0 +1,23 @@
+This is due to missing implementation of do_print_to_mapfile for
+atrributea section (ARM.attributes), it started to show up after fix
+for PR gold/16980 was installed
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+diff --git a/gold/attributes.h b/gold/attributes.h
+index c0b171f..6e3ab8c 100644
+--- a/gold/attributes.h
++++ b/gold/attributes.h
+@@ -387,6 +387,10 @@ class Output_attributes_section_data : public Output_section_data
+ { }
+
+ protected:
++ // Write to a map file.
++ void
++ do_print_to_mapfile(Mapfile* mapfile) const
++ { mapfile->print_output_data(this, _("** attributes")); }
+ // Write the data to the output file.
+ void
+ do_write(Output_file*);
+--
+2.1.4
diff --git a/sys-devel/binutils/files/binutils-configure-LANG.patch b/sys-devel/binutils/files/binutils-configure-LANG.patch
new file mode 100644
index 0000000..5521d19
--- /dev/null
+++ b/sys-devel/binutils/files/binutils-configure-LANG.patch
@@ -0,0 +1,65 @@
+The LANG vars aren't reset early enough so when sed tries to use [a-zA-Z] in
+option parsing, it may break.
+
+http://bugs.gentoo.org/103483
+http://bugs.gentoo.org/122216
+
+--- configure
++++ configure
+@@ -54,6 +54,19 @@
+ infodir='${prefix}/info'
+ mandir='${prefix}/man'
+
++# NLS nuisances.
++for as_var in \
++ LANG LANGUAGE LC_ADDRESS LC_ALL LC_COLLATE LC_CTYPE LC_IDENTIFICATION \
++ LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER \
++ LC_TELEPHONE LC_TIME
++do
++ if (set +x; test -z "`(eval $as_var=C; export $as_var) 2>&1`"); then
++ eval $as_var=C; export $as_var
++ else
++ unset $as_var
++ fi
++done
++
+ # Initialize some other variables.
+ subdirs=
+ MFLAGS= MAKEFLAGS=
+@@ -452,16 +463,6 @@
+ esac
+ done
+
+-# NLS nuisances.
+-# Only set these to C if already set. These must not be set unconditionally
+-# because not all systems understand e.g. LANG=C (notably SCO).
+-# Fixing LC_MESSAGES prevents Solaris sh from translating var values in `set'!
+-# Non-C LC_CTYPE values break the ctype check.
+-if test "${LANG+set}" = set; then LANG=C; export LANG; fi
+-if test "${LC_ALL+set}" = set; then LC_ALL=C; export LC_ALL; fi
+-if test "${LC_MESSAGES+set}" = set; then LC_MESSAGES=C; export LC_MESSAGES; fi
+-if test "${LC_CTYPE+set}" = set; then LC_CTYPE=C; export LC_CTYPE; fi
+-
+ # confdefs.h avoids OS command line length limits that DEFS can exceed.
+ rm -rf conftest* confdefs.h
+ # AIX cpp loses on an empty file, so make sure it contains at least a newline.
+@@ -1850,6 +1850,19 @@
+ # Compiler output produced by configure, useful for debugging
+ # configure, is in ./config.log if it exists.
+
++# NLS nuisances.
++for as_var in \
++ LANG LANGUAGE LC_ADDRESS LC_ALL LC_COLLATE LC_CTYPE LC_IDENTIFICATION \
++ LC_MEASUREMENT LC_MESSAGES LC_MONETARY LC_NAME LC_NUMERIC LC_PAPER \
++ LC_TELEPHONE LC_TIME
++do
++ if (set +x; test -z "`(eval \$as_var=C; export \$as_var) 2>&1`"); then
++ eval \$as_var=C; export \$as_var
++ else
++ unset \$as_var
++ fi
++done
++
+ ac_cs_usage="Usage: $CONFIG_STATUS [--recheck] [--version] [--help]"
+ for ac_option
+ do