summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs/vte/vte-0.28.2-r204.ebuild')
-rw-r--r--x11-libs/vte/vte-0.28.2-r204.ebuild80
1 files changed, 0 insertions, 80 deletions
diff --git a/x11-libs/vte/vte-0.28.2-r204.ebuild b/x11-libs/vte/vte-0.28.2-r204.ebuild
deleted file mode 100644
index 2546772f4da2..000000000000
--- a/x11-libs/vte/vte-0.28.2-r204.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.28.2-r204.ebuild,v 1.9 2013/02/22 20:52:12 zmedico Exp $
-
-EAPI="4"
-GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-PYTHON_DEPEND="python? 2:2.5"
-
-inherit eutils gnome2 python
-
-DESCRIPTION="GNOME terminal widget"
-HOMEPAGE="https://live.gnome.org/VTE"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
-IUSE="debug doc glade +introspection python"
-
-PDEPEND="x11-libs/gnome-pty-helper"
-RDEPEND=">=dev-libs/glib-2.26:2
- >=x11-libs/gtk+-2.20:2[introspection?]
- >=x11-libs/pango-1.22.0
-
- sys-libs/ncurses
- x11-libs/libX11
- x11-libs/libXft
-
- glade? ( dev-util/glade:3 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
- python? ( >=dev-python/pygtk-2.4:2 )"
-DEPEND="${RDEPEND}
- >=dev-util/intltool-0.35
- virtual/pkgconfig
- sys-devel/gettext
- doc? ( >=dev-util/gtk-doc-1.13 )"
-
-pkg_setup() {
- # Do not disable gnome-pty-helper, bug #401389
- G2CONF="${G2CONF}
- --disable-deprecation
- --disable-static
- $(use_enable debug)
- $(use_enable glade glade-catalogue)
- $(use_enable introspection)
- $(use_enable python)
- --with-gtk=2.0"
-
- if [[ ${CHOST} == *-interix* ]]; then
- G2CONF="${G2CONF} --disable-Bsymbolic"
-
- # interix stropts.h is empty...
- export ac_cv_header_stropts_h=no
- fi
-
- DOCS="AUTHORS ChangeLog HACKING NEWS README"
- if use python; then
- python_set_active_version 2
- python_pkg_setup
- fi
-}
-
-src_prepare() {
- # https://bugzilla.gnome.org/show_bug.cgi?id=663779
- epatch "${FILESDIR}/${PN}-0.30.1-alt-meta.patch"
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=652290
- epatch "${FILESDIR}"/${PN}-0.28.2-interix.patch
-
- # Fix CVE-2012-2738, upstream bug #676090
- epatch "${FILESDIR}"/${PN}-0.28.2-limit-arguments.patch
-
- gnome2_src_prepare
-}
-
-src_install() {
- gnome2_src_install
- rm -v "${ED}usr/libexec/gnome-pty-helper" || die
- use python && python_clean_installation_image
-}