summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.0.ebuild')
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.0.ebuild35
1 files changed, 22 insertions, 13 deletions
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.0.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.0.ebuild
index 2f299651e246..3420fcf2a7a0 100644
--- a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.0.ebuild
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.0.ebuild
@@ -1,26 +1,26 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.0.ebuild,v 1.1 2009/10/10 08:04:53 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.0.ebuild,v 1.2 2009/10/12 17:00:03 remi Exp $
-inherit toolchain-funcs eutils x-modular
+inherit linux-info x-modular
DESCRIPTION="Driver for Synaptics touchpads"
HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
-LICENSE="MIT"
IUSE="hal"
+
RDEPEND="
- >=x11-base/xorg-server-1.7.0
- >=x11-libs/libXext-1.1
- >=x11-libs/libXtst-1.1
+ >=x11-base/xorg-server-1.6
+ >=x11-libs/libXi-1.2
+ x11-libs/libXtst
hal? ( sys-apps/hal )"
DEPEND="${RDEPEND}
- !x11-drivers/synaptics
- >=x11-proto/inputproto-2.0
+ x11-proto/inputproto
>=sys-apps/sed-4"
src_install() {
- DOCS="INSTALL NEWS TODO README"
+ DOCS="INSTALL TODO README"
x-modular_src_install
if use hal ; then
@@ -30,12 +30,21 @@ src_install() {
}
pkg_postinst() {
- elog "This driver requires event interface support in your kernel: INPUT_EVDEV"
+ x-modular_pkg_postinst
+ if ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
if use hal ; then
- elog "Synaptics settings are now stored in:"
- elog "/etc/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi"
+ elog "If you want to modify Synaptics settings, please create an fdi file in:"
+ elog "/etc/hal/fdi/policy/"
echo
- ewarn "Please see the examples here for inspiration, but not edit:"
+ ewarn "The current default are set by :"
ewarn "/usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi"
+ ewarn "You can use this file for inspiration, but DO NOT EDIT IT directly."
fi
}