summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-client/chromium/chromium-5.0.375.29.ebuild')
-rw-r--r--www-client/chromium/chromium-5.0.375.29.ebuild205
1 files changed, 205 insertions, 0 deletions
diff --git a/www-client/chromium/chromium-5.0.375.29.ebuild b/www-client/chromium/chromium-5.0.375.29.ebuild
new file mode 100644
index 000000000000..e537341fb037
--- /dev/null
+++ b/www-client/chromium/chromium-5.0.375.29.ebuild
@@ -0,0 +1,205 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-client/chromium/chromium-5.0.375.29.ebuild,v 1.1 2010/05/04 14:51:53 phajdan.jr Exp $
+
+EAPI="2"
+inherit eutils flag-o-matic multilib portability toolchain-funcs
+
+DESCRIPTION="Open-source version of Google Chrome web browser"
+HOMEPAGE="http://chromium.org/"
+SRC_URI="http://build.chromium.org/buildbot/official/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="mp3 +plugins-symlink x264"
+
+RDEPEND="app-arch/bzip2
+ >=dev-libs/libevent-1.4.13
+ dev-libs/libxml2
+ dev-libs/libxslt
+ >=dev-libs/nss-3.12.3
+ >=gnome-base/gconf-2.24.0
+ >=media-libs/alsa-lib-1.0.19
+ media-libs/jpeg:0
+ media-libs/libpng
+ >=media-video/ffmpeg-0.5_p21602[mp3=,threads,x264=]
+ sys-libs/zlib
+ >=x11-libs/gtk+-2.14.7
+ x11-libs/libXScrnSaver"
+# dev-db/sqlite:3
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ >=dev-util/gperf-3.0.3
+ >=dev-util/pkgconfig-0.23
+ sys-devel/flex"
+RDEPEND+="
+ || (
+ x11-themes/gnome-icon-theme
+ x11-themes/oxygen-molecule
+ x11-themes/tango-icon-theme
+ x11-themes/xfce4-icon-theme
+ )
+ x11-misc/xdg-utils
+ virtual/ttf-fonts"
+
+# Incompatible system plugins:
+# www-plugins/gecko-mediaplayer, bug #309231.
+RDEPEND+="
+ plugins-symlink? (
+ !www-plugins/gecko-mediaplayer[gnome]
+ )"
+
+pkg_setup() {
+ if [[ "${ROOT}" == "/" ]]; then
+ # Prevent user problems like bug 299777.
+ if ! grep -q /dev/shm <<< $(get_mounts); then
+ eerror "You don't have tmpfs mounted at /dev/shm."
+ eerror "${PN} isn't going to work in that configuration."
+ eerror "Please uncomment the /dev/shm entry in /etc/fstab,"
+ eerror "run 'mount /dev/shm' and try again."
+ die "/dev/shm is not mounted"
+ fi
+ if [ `stat -c %a /dev/shm` -ne 1777 ]; then
+ eerror "/dev/shm does not have correct permissions."
+ eerror "${PN} isn't going to work in that configuration."
+ eerror "Please run chmod 1777 /dev/shm and try again."
+ die "/dev/shm has incorrect permissions"
+ fi
+ fi
+
+ elog "${PN} might crash occasionally. To get more useful backtraces"
+ elog "and submit better bug reports, please read"
+ elog "http://www.gentoo.org/proj/en/qa/backtraces.xml"
+}
+
+src_prepare() {
+ # Prevent automatic -march=pentium4 -msse2 enabling on x86, http://crbug.com/9007
+ epatch "${FILESDIR}"/${PN}-drop_sse2-r0.patch
+
+ # Allow supporting more media types provided system ffmpeg supports them.
+ epatch "${FILESDIR}"/${PN}-supported-media-mime-types.patch
+
+ # Fix build failure with libpng-1.4, bug 310959.
+ epatch "${FILESDIR}"/${PN}-libpng-1.4.patch
+}
+
+src_configure() {
+ export CHROMIUM_HOME=/usr/$(get_libdir)/chromium-browser
+
+ # Fails to build on arm if we don't do this
+ use arm && append-flags -fno-tree-sink
+
+ if use mp3 ; then
+ append-cflags -DGENTOO_CHROMIUM_MP3_ENABLED
+ fi
+
+ if use x264 ; then
+ append-cflags -DGENTOO_CHROMIUM_H264_ENABLED
+ fi
+
+ # CFLAGS/LDFLAGS
+ mkdir -p "${S}"/.gyp || die "cflags mkdir failed"
+ cat << EOF > "${S}"/.gyp/include.gypi || die "cflags cat failed"
+{
+ 'target_defaults': {
+ 'cflags': [ '${CFLAGS// /','}' ],
+ 'ldflags': [ '${LDFLAGS// /','}' ],
+ },
+}
+EOF
+ export HOME="${S}"
+
+ # Configuration options (system libraries)
+ local myconf="-Duse_system_zlib=1 -Duse_system_bzip2=1 -Duse_system_ffmpeg=1 -Duse_system_libevent=1 -Duse_system_libjpeg=1 -Duse_system_libpng=1 -Duse_system_libxml=1 -Duse_system_libxslt=1"
+ # -Duse_system_sqlite=1 : http://crbug.com/22208
+ # Others still bundled: icu (not possible?), hunspell (changes required for sandbox support)
+
+ # Sandbox paths
+ myconf="${myconf} -Dlinux_sandbox_path=${CHROMIUM_HOME}/chrome_sandbox -Dlinux_sandbox_chrome_path=${CHROMIUM_HOME}/chrome"
+
+ # Disable the V8 snapshot. It breaks the build on hardened (bug #301880),
+ # and the performance gain isn't worth it.
+ myconf="${myconf} -Dv8_use_snapshot=0"
+
+ # Use target arch detection logic from bug #296917.
+ local myarch="$ABI"
+ [[ $myarch = "" ]] && myarch="$ARCH"
+
+ if [[ $myarch = amd64 ]] ; then
+ myconf="${myconf} -Dtarget_arch=x64"
+ elif [[ $myarch = x86 ]] ; then
+ myconf="${myconf} -Dtarget_arch=ia32"
+ elif [[ $myarch = arm ]] ; then
+ myconf="${myconf} -Dtarget_arch=arm -Ddisable_nacl=1 -Dlinux_use_tcmalloc=0"
+ else
+ die "Failed to determine target arch, got '$myarch'."
+ fi
+
+ if [[ "$(gcc-major-version)$(gcc-minor-version)" == "44" ]]; then
+ myconf="${myconf} -Dno_strict_aliasing=1 -Dgcc_version=44"
+ fi
+
+ # Make sure that -Werror doesn't get added to CFLAGS by the build system.
+ # Depending on GCC version the warnings are different and we don't want
+ # the build to fail because of that.
+ myconf="${myconf} -Dwerror="
+
+ build/gyp_chromium -f make build/all.gyp ${myconf} --depth=. || die "gyp failed"
+}
+
+src_compile() {
+ emake -r V=1 chrome chrome_sandbox BUILDTYPE=Release \
+ rootdir="${S}" \
+ CC=$(tc-getCC) \
+ CXX=$(tc-getCXX) \
+ AR=$(tc-getAR) \
+ RANLIB=$(tc-getRANLIB) \
+ || die "compilation failed"
+}
+
+src_install() {
+ # Chromium does not have "install" target in the build system.
+ export CHROMIUM_HOME=/usr/$(get_libdir)/chromium-browser
+
+ dodir ${CHROMIUM_HOME}
+
+ exeinto ${CHROMIUM_HOME}
+ doexe out/Release/chrome
+ doexe out/Release/chrome_sandbox
+ fperms 4755 ${CHROMIUM_HOME}/chrome_sandbox
+ doexe out/Release/xdg-settings
+ doexe "${FILESDIR}"/chromium-launcher.sh
+
+ insinto ${CHROMIUM_HOME}
+ doins out/Release/chrome.pak
+
+ doins -r out/Release/locales
+ doins -r out/Release/resources
+
+ # chrome.1 is for chromium --help
+ newman out/Release/chrome.1 chrome.1
+ newman out/Release/chrome.1 chromium.1
+
+ # Chromium looks for these in its folder
+ # See media_posix.cc and base_paths_linux.cc
+ dosym /usr/$(get_libdir)/libavcodec.so.52 ${CHROMIUM_HOME}
+ dosym /usr/$(get_libdir)/libavformat.so.52 ${CHROMIUM_HOME}
+ dosym /usr/$(get_libdir)/libavutil.so.50 ${CHROMIUM_HOME}
+
+ # Plugins symlink, optional wrt bug #301911
+ if use plugins-symlink; then
+ dosym /usr/$(get_libdir)/nsbrowser/plugins ${CHROMIUM_HOME}/plugins
+ fi
+
+ # Icon and desktop entry
+ newicon out/Release/product_logo_48.png ${PN}-browser.png
+ dosym ${CHROMIUM_HOME}/chromium-launcher.sh /usr/bin/chromium
+ make_desktop_entry chromium "Chromium" ${PN}-browser "Network;WebBrowser"
+ sed -e "/^Exec/s/$/ %U/" -i "${D}"/usr/share/applications/*.desktop \
+ || die "desktop file sed failed"
+ # Gnome default application entry
+ dodir /usr/share/gnome-control-center/default-apps
+ insinto /usr/share/gnome-control-center/default-apps
+ doins "${FILESDIR}"/chromium.xml
+}