summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/mythweb/mythweb-0.21_p16468.ebuild')
-rw-r--r--www-apps/mythweb/mythweb-0.21_p16468.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/www-apps/mythweb/mythweb-0.21_p16468.ebuild b/www-apps/mythweb/mythweb-0.21_p16468.ebuild
new file mode 100644
index 000000000000..4895abe540c3
--- /dev/null
+++ b/www-apps/mythweb/mythweb-0.21_p16468.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/mythweb/mythweb-0.21_p16468.ebuild,v 1.1 2008/03/09 20:48:14 cardoe Exp $
+
+ESVN_PROJECT="mythplugins"
+
+inherit mythtv webapp depend.php subversion
+
+DESCRIPTION="PHP scripts intended to manage MythTV from a web browser."
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="dev-perl/DBI
+ dev-perl/DBD-mysql"
+
+need_httpd_cgi
+need_php5_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_php_with_use session mysql pcre posix
+}
+
+src_unpack() {
+ subversion_src_unpack
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ webapp_src_preinst
+
+ cd "${S}"/mythweb
+ dodoc README TODO
+
+ dodir "${MY_HTDOCSDIR}"/data
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r [[:lower:]]*
+
+ webapp_configfile "${MY_HTDOCSDIR}"/mythweb.conf.{apache,lighttpd}
+
+ webapp_serverowned "${MY_HTDOCSDIR}"/data
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en-0.21.txt
+
+ webapp_src_install
+}