summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/horde/horde-3.0.5.ebuild')
-rw-r--r--www-apps/horde/horde-3.0.5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/www-apps/horde/horde-3.0.5.ebuild b/www-apps/horde/horde-3.0.5.ebuild
new file mode 100644
index 000000000000..d586dd063f0c
--- /dev/null
+++ b/www-apps/horde/horde-3.0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/horde/horde-3.0.5.ebuild,v 1.1 2005/08/07 21:58:07 vapier Exp $
+
+inherit horde
+
+DESCRIPTION="Horde Application Framework"
+HOMEPAGE="http://www.horde.org/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="mysql"
+
+DEPEND=""
+RDEPEND="virtual/php
+ >=sys-devel/gettext-0.10.40
+ >=dev-libs/libxml2-2.4.21
+ >=www-apps/horde-pear-1.3
+ dev-php/PEAR-Log
+ dev-php/PEAR-Mail_Mime
+ mysql? ( dev-php/PEAR-DB )"
+
+EHORDE_PATCHES="${FILESDIR}/horde-3.0.4-freebusy.patch"
+
+pkg_setup() {
+ has_version '>=virtual/php-5' \
+ && HORDE_PHP_FEATURES="nls session xml2" \
+ || HORDE_PHP_FEATURES="nls"
+ horde_pkg_setup
+}
+
+pkg_postinst() {
+ horde_pkg_postinst
+ echo
+ einfo "Horde requires PHP to have:"
+ einfo " ==> 'short_open_tag enabled = On'"
+ einfo " ==> 'magic_quotes_runtime set = Off'"
+ einfo " ==> 'file_uploads enabled = On'"
+ einfo "Please edit /etc/php/apache2-php4/php.ini"
+}