summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'www-apps/ampache/ampache-3.4.3.ebuild')
-rw-r--r--www-apps/ampache/ampache-3.4.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/www-apps/ampache/ampache-3.4.3.ebuild b/www-apps/ampache/ampache-3.4.3.ebuild
new file mode 100644
index 000000000000..898de35b1efc
--- /dev/null
+++ b/www-apps/ampache/ampache-3.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-apps/ampache/ampache-3.4.3.ebuild,v 1.1 2008/09/15 11:49:43 wrobel Exp $
+
+inherit webapp depend.php
+
+DESCRIPTION="Ampache is a PHP-based tool for managing, updating and playing your audio files via a web interface."
+HOMEPAGE="http://www.ampache.org/"
+SRC_URI="http://www.ampache.org/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+need_httpd_cgi
+need_php_httpd
+
+pkg_setup() {
+ webapp_pkg_setup
+ require_php_with_use pcre session unicode iconv xml mysql gd zlib
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc docs/*
+ rm -rf docs/
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ webapp_postinst_txt en "${FILESDIR}"/installdoc.txt
+ webapp_src_install
+}