summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/rar2fs/rar2fs-1.16.0.ebuild')
-rw-r--r--sys-fs/rar2fs/rar2fs-1.16.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-fs/rar2fs/rar2fs-1.16.0.ebuild b/sys-fs/rar2fs/rar2fs-1.16.0.ebuild
new file mode 100644
index 000000000000..5e42a9c9d6d5
--- /dev/null
+++ b/sys-fs/rar2fs/rar2fs-1.16.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/rar2fs/rar2fs-1.16.0.ebuild,v 1.1 2013/03/13 07:53:35 ssuominen Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A FUSE based filesystem that can mount one or multiple RAR archive(s)"
+HOMEPAGE="http://code.google.com/p/rar2fs/"
+SRC_URI="http://rar2fs.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=app-arch/unrar-4.2:=
+ sys-fs/fuse"
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-destdir.patch
+ eautoreconf
+}
+
+src_configure() {
+ export USER_CFLAGS="${CFLAGS}"
+
+ local mydebug
+ use debug && mydebug="--enable-debug=4"
+
+ econf \
+ --with-unrar=/usr/include/libunrar \
+ ${mydebug}
+}