summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/sparse/files/sparse-0.3-makefile-fix.patch')
-rw-r--r--sys-devel/sparse/files/sparse-0.3-makefile-fix.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch b/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch
new file mode 100644
index 000000000000..03dafa1f5715
--- /dev/null
+++ b/sys-devel/sparse/files/sparse-0.3-makefile-fix.patch
@@ -0,0 +1,24 @@
+--- sparse-0.3/work/sparse-0.3/Makefile 2007-06-15 14:21:33.000000000 +0200
++++ sparse-0.3-new/work/sparse-0.3/Makefile 2007-06-15 14:21:51.000000000 +0200
+@@ -16,9 +16,9 @@ AR=ar
+ CFLAGS += -DDEBUG
+
+ DESTDIR=
+-PREFIX=$(HOME)
+-BINDIR=$(PREFIX)/bin
+-LIBDIR=$(PREFIX)/lib
++PREFIX=
++BINDIR=$(PREFIX)/usr/bin
++LIBDIR=$(PREFIX)/usr/lib
+ INCLUDEDIR=$(PREFIX)/include
+ PKGCONFIGDIR=$(LIBDIR)/pkgconfig
+
+@@ -38,7 +38,7 @@ LIB_OBJS= target.o parse.o tokenize.o pr
+ LIB_FILE= libsparse.a
+ SLIB_FILE= libsparse.so
+
+-LIBS=$(LIB_FILE)
++LIBS=$(SLIB_FILE)
+
+ all: $(PROGRAMS) sparse.pc
+