summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-devel/automake/automake-9999.ebuild')
-rw-r--r--sys-devel/automake/automake-9999.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-devel/automake/automake-9999.ebuild b/sys-devel/automake/automake-9999.ebuild
new file mode 100644
index 000000000000..7752d8bd9227
--- /dev/null
+++ b/sys-devel/automake/automake-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-9999.ebuild,v 1.1 2007/11/02 06:17:52 vapier Exp $
+
+EGIT_REPO_URI="git://git.savannah.gnu.org/automake.git"
+
+inherit eutils git
+
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+HOMEPAGE="http://sources.redhat.com/automake/"
+SRC_URI=""
+
+LICENSE="GPL-3"
+SLOT="${PV:0:4}"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ >=sys-devel/automake-wrapper-2
+ >=sys-devel/autoconf-2.60
+ >=sys-apps/texinfo-4.7
+ sys-devel/gnuconfig"
+DEPEND="${RDEPEND}
+ sys-apps/help2man"
+
+src_unpack() {
+ git_src_unpack
+ cd "${S}"
+ sed -i \
+ -e "s|: (automake)| v${SLOT}: (automake${SLOT})|" \
+ doc/automake.texi || die "sed failed"
+ export WANT_AUTOCONF=2.5
+}
+
+src_compile() {
+ econf --docdir=/usr/share/doc/${PF} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc NEWS README THANKS TODO AUTHORS ChangeLog
+
+ # SLOT the docs and junk
+ local x
+ for x in aclocal automake ; do
+ help2man ./${x} > ${x}-${SLOT}.1
+ doman ${x}-${SLOT}.1
+ rm -f "${D}"/usr/bin/${x}
+ done
+ cd "${D}"/usr/share/info || die
+ for x in *.info* ; do
+ mv "${x}" "${x/${PN}/${PN}${SLOT}}" || die
+ done
+
+ # remove all config.guess and config.sub files replacing them
+ # w/a symlink to a specific gnuconfig version
+ for x in guess sub ; do
+ dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
+ done
+}