summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-cluster/cman-lib/cman-lib-2.03.09.ebuild')
-rw-r--r--sys-cluster/cman-lib/cman-lib-2.03.09.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-cluster/cman-lib/cman-lib-2.03.09.ebuild b/sys-cluster/cman-lib/cman-lib-2.03.09.ebuild
index 841b840dad81..5dc487944741 100644
--- a/sys-cluster/cman-lib/cman-lib-2.03.09.ebuild
+++ b/sys-cluster/cman-lib/cman-lib-2.03.09.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman-lib/cman-lib-2.03.09.ebuild,v 1.3 2009/02/10 22:31:27 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman-lib/cman-lib-2.03.09.ebuild,v 1.4 2010/10/20 12:34:52 cla Exp $
inherit eutils versionator
@@ -37,6 +37,9 @@ src_compile() {
--sominor="$MIN_PV" \
) || die "configure problem"
+ sed -e 's:\($(CC)\):\1 $(LDFLAGS):' -i Makefile
+ sed -e 's:\($(CC)\):\1 $(LDFLAGS):' -i "${WORKDIR}/${MY_P}/make/cobj.mk"
+
emake clean || die "clean problem"
emake || die "compile problem"
}