summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/thinkpad/thinkpad-3.2.ebuild')
-rw-r--r--sys-apps/thinkpad/thinkpad-3.2.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/sys-apps/thinkpad/thinkpad-3.2.ebuild b/sys-apps/thinkpad/thinkpad-3.2.ebuild
deleted file mode 100644
index 1d517c73ba2a..000000000000
--- a/sys-apps/thinkpad/thinkpad-3.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/thinkpad/thinkpad-3.2.ebuild,v 1.13 2003/09/07 00:52:20 msterret Exp $
-
-#transform P to match tarball versioning
-MYPV=${PV/_beta/beta}
-MYP="${PN}_${MYPV}"
-KV=""
-DESCRIPTION="Thinkpad system control kernel modules"
-SRC_URI="mirror://sourceforge/tpctl/${MYP}.tar.gz"
-HOMEPAGE="http://tpctl.sourceforge.net/tpctlhome.htm"
-KEYWORDS="x86 amd64 -ppc -mips"
-SLOT="0"
-LICENSE="GPL-2"
-
-#virtual/glibc should depend on specific kernel headers
-DEPEND="virtual/glibc"
-
-pkg_setup() {
- #thinkpad will compile modules for the kernel pointed to by /usr/src/linux
- KV=`readlink /usr/src/linux`
- if [ $? -ne 0 ] ; then
- echo
- echo "/usr/src/linux symlink does not exist; cannot continue."
- echo
- die
- else
- KV=${KV/linux-/}
- fi
-}
-
-src_compile() {
- emake || die "Make failed"
-}
-
-src_install() {
- dodoc AUTHORS COPYING ChangeLog README SUPPORTED-MODELS TECHNOTES
- dodir /lib/modules/${KV}/thinkpad
- cp ${S}/drivers/{thinkpad,smapi,superio,rtcmosram,thinkpadpm}.o \
- ${D}/lib/modules/${KV}/thinkpad
- insinto /etc/modules.d
- doins ${FILESDIR}/thinkpad
- (cat /etc/devfsd.conf; echo; echo '# Thinkpad config';
- echo 'REGISTER ^thinkpad/.*$ PERMISSIONS root.thinkpad 0664') \
- > ${D}/etc/devfsd.conf
-}
-
-pkg_postinst() {
- /usr/sbin/update-modules || return 0
-}
-
-pkg_prerm() {
- /sbin/modprobe -r smapi superion rtcmosram thinkpadpm thinkpad
-}