summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/chpax/chpax-0.6.1.ebuild')
-rw-r--r--sys-apps/chpax/chpax-0.6.1.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/sys-apps/chpax/chpax-0.6.1.ebuild b/sys-apps/chpax/chpax-0.6.1.ebuild
index 204a7077642b..1ee3187c8916 100644
--- a/sys-apps/chpax/chpax-0.6.1.ebuild
+++ b/sys-apps/chpax/chpax-0.6.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/chpax/chpax-0.6.1.ebuild,v 1.12 2004/06/30 14:37:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/chpax/chpax-0.6.1.ebuild,v 1.13 2004/10/28 20:31:27 solar Exp $
-inherit flag-o-matic gcc
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Manages various PaX related flags for ELF32, ELF64, and a.out binaries."
HOMEPAGE="http://pax.grsecurity.net/"
@@ -14,8 +14,8 @@ SLOT="0"
KEYWORDS="x86 ppc sparc ~mips alpha ~arm hppa amd64 ia64"
IUSE=""
-DEPEND="virtual/libc
- >=sys-apps/sed-4"
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND} >=sys-apps/sed-4"
src_unpack() {
unpack ${A}
@@ -25,7 +25,7 @@ src_unpack() {
src_compile() {
# use static && append-ldflags -static ; # breaks with current ssp.
- emake CC="$(gcc-getCC)" TARGET="chpax ${LDFLAGS:0}" || die "Parallel Make Failed"
+ emake CC="$(tc-getCC)" TARGET="chpax ${LDFLAGS:0}" || die "Parallel Make Failed"
}
src_install() {