summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/freemat/freemat-3.5.ebuild')
-rw-r--r--sci-mathematics/freemat/freemat-3.5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/sci-mathematics/freemat/freemat-3.5.ebuild b/sci-mathematics/freemat/freemat-3.5.ebuild
new file mode 100644
index 000000000000..f94fbba5b3a9
--- /dev/null
+++ b/sci-mathematics/freemat/freemat-3.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/freemat/freemat-3.5.ebuild,v 1.1 2007/09/25 19:27:56 bicatali Exp $
+
+inherit eutils flag-o-matic autotools qt4
+
+MY_PN=FreeMat
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Environment for rapid engineering and scientific prototyping and data processing"
+HOMEPAGE="http://freemat.sourceforge.net/"
+SRC_URI="mirror://sourceforge/freemat/${MY_P}.tar.gz"
+
+IUSE="ncurses ffcall fftw umfpack arpack portaudio"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-libs/libpcre
+ virtual/lapack
+ dev-util/pkgconfig
+ ncurses? ( >=sys-libs/ncurses-5.4 )
+ umfpack? ( sci-libs/umfpack )
+ arpack? ( sci-libs/arpack )
+ fftw? ( >=sci-libs/fftw-3 )
+ portaudio? ( media-libs/portaudio )"
+
+RDEPEND="${DEPEND}
+ ffcall? ( dev-libs/ffcall )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # -O3 still doesn't compile freemat-3.5
+ replace-flags -O3 -O2
+ econf $(use_with ncurses) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README AUTHORS ChangeLog || die "dodoc failed"
+}
+
+pkg_postint() {
+ einfo "Initializing freemat data directory"
+ FreeMat -i /usr/share/${MY_P}
+}