summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/agda/agda-2.3.0.ebuild')
-rw-r--r--sci-mathematics/agda/agda-2.3.0.ebuild36
1 files changed, 21 insertions, 15 deletions
diff --git a/sci-mathematics/agda/agda-2.3.0.ebuild b/sci-mathematics/agda/agda-2.3.0.ebuild
index 469ba891b76e..72abd016e20d 100644
--- a/sci-mathematics/agda/agda-2.3.0.ebuild
+++ b/sci-mathematics/agda/agda-2.3.0.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.0.ebuild,v 1.1 2012/01/23 13:52:38 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-mathematics/agda/agda-2.3.0.ebuild,v 1.2 2012/03/25 13:55:19 gienah Exp $
# ebuild generated by hackport 0.2.14
-EAPI="3"
+EAPI="4"
-CABAL_FEATURES="lib"
+CABAL_FEATURES="lib profile"
inherit haskell-cabal eutils elisp-common
MY_PN="Agda"
@@ -19,19 +19,20 @@ SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="epic"
+IUSE="epic +stdlib"
-RDEPEND="<dev-haskell/binary-0.6
- epic? ( dev-lang/epic )
- =dev-haskell/hashable-1.1*
- =dev-haskell/hashtables-1.0*
- >=dev-haskell/haskeline-0.6.3.2
- >=dev-haskell/haskell-src-exts-1.9.6
- =dev-haskell/mtl-2.0*
- =dev-haskell/quickcheck-2.4*
- =dev-haskell/xhtml-3000.2*
- <dev-haskell/zlib-0.6
+RDEPEND="<dev-haskell/binary-0.6[profile?]
+ epic? ( dev-lang/epic[profile?] )
+ =dev-haskell/hashable-1.1*[profile?]
+ =dev-haskell/hashtables-1.0*[profile?]
+ >=dev-haskell/haskeline-0.6.3.2[profile?]
+ >=dev-haskell/haskell-src-exts-1.9.6[profile?]
+ =dev-haskell/mtl-2.0*[profile?]
+ =dev-haskell/quickcheck-2.4*[profile?]
+ =dev-haskell/xhtml-3000.2*[profile?]
+ <dev-haskell/zlib-0.6[profile?]
>=dev-lang/ghc-6.10.4"
+PDEPEND="stdlib? ( sci-mathematics/agda-stdlib )"
DEPEND="${RDEPEND}
dev-haskell/alex
>=dev-haskell/cabal-1.8
@@ -41,9 +42,14 @@ SITEFILE="50${PN}2-gentoo.el"
S="${WORKDIR}/${MY_P}"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-emacs.patch
+ epatch "${FILESDIR}"/${P}-ghc-7.4.patch
sed -e 's@epic >= 0.1.13 && < 0.2@epic >= 0.1.13 \&\& < 0.10@' \
+ -e 's@base >= 4.2 && < 4.5@base >= 4.2 \&\& < 4.6@' \
+ -e 's@array >= 0.1 && < 0.4@array >= 0.1 \&\& < 0.5@' \
+ -e 's@filepath >= 1.1 && < 1.3@filepath >= 1.1 \&\& < 1.4@' \
+ -e 's@old-time == 1.0.\*@old-time >= 1.0 \&\& < 1.2@' \
-i "${S}/${MY_PN}.cabal" || die "Could not loosen dependencies"
- epatch "${FILESDIR}"/${P}-emacs.patch
cabal-mksetup
}