summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/mathgl/mathgl-1.10.ebuild')
-rw-r--r--sci-libs/mathgl/mathgl-1.10.ebuild11
1 files changed, 8 insertions, 3 deletions
diff --git a/sci-libs/mathgl/mathgl-1.10.ebuild b/sci-libs/mathgl/mathgl-1.10.ebuild
index 145e6cf1af05..87850d5b2bf0 100644
--- a/sci-libs/mathgl/mathgl-1.10.ebuild
+++ b/sci-libs/mathgl/mathgl-1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.10.ebuild,v 1.1 2010/01/04 12:02:51 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.10.ebuild,v 1.2 2010/01/30 09:36:07 grozin Exp $
EAPI=2
WX_GTK_VER=2.8
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc fltk gif glut gsl hdf5 jpeg octave python qt4 wxwidgets"
+IUSE="doc fltk gif glut gsl hdf5 jpeg mpi octave python qt4 wxwidgets"
RDEPEND="media-libs/libpng
virtual/glu
@@ -22,8 +22,9 @@ RDEPEND="media-libs/libpng
fltk? ( x11-libs/fltk:1.1 )
gif? ( media-libs/giflib )
jpeg? ( media-libs/jpeg )
- hdf5? ( >=sci-libs/hdf5-1.8 )
+ hdf5? ( >=sci-libs/hdf5-1.8[mpi=] )
gsl? ( sci-libs/gsl )
+ mpi? ( virtual/mpi[cxx] )
octave? ( sci-mathematics/octave )
qt4? ( x11-libs/qt-gui:4 )
wxwidgets? ( x11-libs/wxGTK:2.8 )"
@@ -38,6 +39,10 @@ pkg_setup() {
eerror "You need >=gcc-4.3.0 to compile this package"
die "Wrong gcc version"
fi
+ if use mpi; then
+ export CC=mpicc
+ export CXX=mpicxx
+ fi
}
src_prepare() {