summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/gpx-viewer/gpx-viewer-0.3.0.ebuild')
-rw-r--r--sci-geosciences/gpx-viewer/gpx-viewer-0.3.0.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/sci-geosciences/gpx-viewer/gpx-viewer-0.3.0.ebuild b/sci-geosciences/gpx-viewer/gpx-viewer-0.3.0.ebuild
index 9890f6f9d9d8..4c768f3fabb1 100644
--- a/sci-geosciences/gpx-viewer/gpx-viewer-0.3.0.ebuild
+++ b/sci-geosciences/gpx-viewer/gpx-viewer-0.3.0.ebuild
@@ -1,12 +1,13 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpx-viewer/gpx-viewer-0.3.0.ebuild,v 1.2 2012/10/07 10:02:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpx-viewer/gpx-viewer-0.3.0.ebuild,v 1.3 2013/04/07 16:47:42 jlec Exp $
EAPI=4
AUTOTOOLS_AUTORECONF=yes
+VALA_MIN_API_VERSION=0.16
-inherit autotools-utils gnome2
+inherit autotools-utils gnome2 vala
DESCRIPTION="Simple program to visualize a gpx file"
HOMEPAGE="http://blog.sarine.nl/gpx-viewer/"
@@ -17,27 +18,25 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="nls"
-MY_VALA_VERSION=0.16
-
RDEPEND="
- dev-lang/vala:${MY_VALA_VERSION}
dev-libs/gdl:3
dev-libs/glib:2
dev-libs/libxml2:2
media-libs/libchamplain:0.12[gtk]
x11-libs/gtk+:3"
DEPEND="${RDEPEND}
+ ${vala_depend}
>=dev-util/intltool-0.21
virtual/pkgconfig"
src_prepare() {
- export VALAC="$(type -P valac-${MY_VALA_VERSION})"
sed \
-e '/desktopdir/s:$(DESTDIR)::g' \
-i Makefile.am || die
sed \
-e '/MimeType/s:$:;:g' \
-i data/gpx-viewer.desktop.in || die
+ vala_src_prepare
autotools-utils_src_prepare
}