summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/validation/ChangeLog11
-rw-r--r--sci-chemistry/validation/Manifest5
-rw-r--r--sci-chemistry/validation/files/digest-validation-8.0611
-rw-r--r--sci-chemistry/validation/files/respect-flags-and-add-gcc4.patch302
-rw-r--r--sci-chemistry/validation/metadata.xml9
-rw-r--r--sci-chemistry/validation/validation-8.061.ebuild63
6 files changed, 391 insertions, 0 deletions
diff --git a/sci-chemistry/validation/ChangeLog b/sci-chemistry/validation/ChangeLog
new file mode 100644
index 000000000000..3a643f55eae1
--- /dev/null
+++ b/sci-chemistry/validation/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-chemistry/validation
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/validation/ChangeLog,v 1.1 2005/12/19 01:27:20 spyderous Exp $
+
+*validation-8.061 (19 Dec 2005)
+
+ 19 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/respect-flags-and-add-gcc4.patch, +metadata.xml,
+ +validation-8.061.ebuild:
+ Add a set of tools used by the PDB for processing and checking structure data.
+
diff --git a/sci-chemistry/validation/Manifest b/sci-chemistry/validation/Manifest
new file mode 100644
index 000000000000..2e2b964f6fb0
--- /dev/null
+++ b/sci-chemistry/validation/Manifest
@@ -0,0 +1,5 @@
+MD5 2eb903ccb2fb2e8310272683a4285797 ChangeLog 480
+MD5 2945df7eb475ba3da5fba282404ba5ec files/digest-validation-8.061 79
+MD5 421aafb0b5804b42f03607840f617113 files/respect-flags-and-add-gcc4.patch 10342
+MD5 af1bfbb0777267a03e889b08173f2757 metadata.xml 248
+MD5 ad76c0c0c8bcd9dd6e3350c3290af124 validation-8.061.ebuild 1617
diff --git a/sci-chemistry/validation/files/digest-validation-8.061 b/sci-chemistry/validation/files/digest-validation-8.061
new file mode 100644
index 000000000000..b9c84095bad7
--- /dev/null
+++ b/sci-chemistry/validation/files/digest-validation-8.061
@@ -0,0 +1 @@
+MD5 889197a71e0e2048046fb14ac9201fdc validation-v8.061-prod-src.tar.gz 5477579
diff --git a/sci-chemistry/validation/files/respect-flags-and-add-gcc4.patch b/sci-chemistry/validation/files/respect-flags-and-add-gcc4.patch
new file mode 100644
index 000000000000..e1304f68c83f
--- /dev/null
+++ b/sci-chemistry/validation/files/respect-flags-and-add-gcc4.patch
@@ -0,0 +1,302 @@
+diff -urN -x cifparse-obj-v6.3 -x make.log -x Makefile.platform validation-v8.061-prod-src.orig/etc/make.platform.gnu3 validation-v8.061-prod-src/etc/make.platform.gnu3
+--- validation-v8.061-prod-src.orig/etc/make.platform.gnu3 2004-08-20 08:26:48.000000000 -0700
++++ validation-v8.061-prod-src/etc/make.platform.gnu3 2005-12-18 16:34:18.000000000 -0800
+@@ -107,8 +107,8 @@
+ C_WARNINGS=$(WARNINGS)
+
+ # C compiler flags
+-CFLAGS=$(OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
+-CFLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
++CFLAGS=$(C_OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+
+ ## C++ compiler
+@@ -125,12 +125,12 @@
+ # This variable specifies how to compile the C code. If it is set to C,
+ # that indicates that C code will be compiled with the C++ compiler.
+ # Otherwise it will be compiled with C compiler.
+-EXT=C
++EXT=c
+
+ # C++ compiler flags
+-C++FLAGS=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
++C++FLAGS=$(CCC_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
+ $(INCLUDES)
+-C++FLAGS_NONANSI=$(OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++C++FLAGS_NONANSI=$(CCC_OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
+ $(DEFINES) $(INCLUDES)
+ # C++FLAGS_RELAXED should be set to avoid warnings reported by third party
+ # source code that is not maintained by PDB
+@@ -144,7 +144,7 @@
+ F77=f77
+
+ # Fortran compiler flags
+-FFLAGS=-O -u
++FFLAGS=$(F_OPT)
+
+ # Additional Fortran libraries
+ F77LIBS=
+diff -urN -x cifparse-obj-v6.3 -x make.log -x Makefile.platform validation-v8.061-prod-src.orig/etc/make.platform.gnu4 validation-v8.061-prod-src/etc/make.platform.gnu4
+--- validation-v8.061-prod-src.orig/etc/make.platform.gnu4 1969-12-31 16:00:00.000000000 -0800
++++ validation-v8.061-prod-src/etc/make.platform.gnu4 2005-12-18 16:34:12.000000000 -0800
+@@ -0,0 +1,202 @@
++##########################################################################
++##
++## File: make.plaform.gnu3
++## Purpose: This file is a Linux platform makefile that supports GNU 3.x
++## compiler suite.
++##
++##########################################################################
++
++#-----Lexer and Parser section-------------------------------------------#
++
++# Lexer executable
++LEX=flex
++
++# Lexer flags
++LEXFLAGS=-Cfr -L
++
++# Parser executable
++YACC=bison
++
++# Parser flags
++YACCFLAGS=-d -v -l
++
++#------------------------------------------------------------------------#
++
++#-----Compilers section--------------------------------------------------#
++
++## ABI
++## This part defines an application binary interface to be used with the
++## compiler suite.
++ABI=
++
++## Warnings flags
++## This part defines warnings related flags
++
++# WARNINGS_AS_ERRORS defines flags to instruct all compilers to treat all
++# warnings as errors.
++
++# ALL_WARNINGS defines flags to instruct all compilers to report all
++# warnings.
++ALL_WARNINGS=-Wall
++
++# NO_DEPRECATED defines flags to instruct C++ compiler not to report
++# warnings about deprecated constructs still used in C++ code.
++NO_DEPRECATED=-Wno-deprecated
++
++# Collect all general warnings related flags
++WARNINGS=$(WARNINGS_AS_ERRORS) $(ALL_WARNINGS)
++
++## Platform specifics
++## This part defines platform specific information
++
++# Endianess.
++# Should be defined only for big endian platforms. Otherwise
++# it must be left undefined, which indicates little endian platform.
++#ENDIANESS=-DBIG_ENDIAN_PLATFORM
++
++# OS indicator. Should be defined only if SunOS is the platform
++#PLATFORM_OS=-DSUN_OS
++
++# Collect all platform related flags
++PLATFORM=$(ENDIANESS) $(PLATFORM_OS)
++
++## Compiler capabilities/restrictions related defines
++## This part defines variables based on the capabilities or restrictions
++## of the compiler suite used on the platform.
++
++# If STRCASECMP_OPTION is defined, that indicates that the compiler
++# suite/supporting libraries support strcasecmp() function.
++STRCASECMP_OPTION=-DHAVE_STRCASECMP
++
++# If INCL_TEMPLATE_SRC_OPTION is defined, that indicates that
++# compiler must include template method definition in template
++# header files in order to properly compile templates.
++INCL_TEMPLATE_SRC_OPTION=-DINCL_TEMPLATE_SRC
++
++# If PLACEMENT_NEW_OPTION is defined, that indicates that the compiler
++# suite/supporting libraries support placement new/delete operators.
++PLACEMENT_NEW_OPTION=-DHAVE_PLACEMENT_NEW
++
++# Collect all compiler capabilities/restrictions
++COMPILER=$(STRCASECMP_OPTION) $(INCL_TEMPLATE_SRC_OPTION) \
++ $(PLACEMENT_NEW_OPTION)
++
++# Collect all global defines
++GDEFINES=$(PLATFORM) $(COMPILER)
++
++# Collect all defines from global defines and defines specified in
++# module makefile
++DEFINES=$(GDEFINES) $(LDEFINES)
++
++## Global include directories
++GINCLUDES=
++
++# Collect all include directories from global include directories and
++# include directories specified in module makefile
++INCLUDES=$(LINCLUDES) $(GINCLUDES)
++
++## C compiler
++## This part defines C compiler information
++
++# C compiler executable
++CC=gcc
++
++# C compiler ANSI/NON-ANSI flags
++ANSI_C_FLAG=-ansi
++NON_ANSI_C_FLAG=
++C_WARNINGS=$(WARNINGS)
++
++# C compiler flags
++CFLAGS=$(C_OPT) $(ABI) $(ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) $(INCLUDES)
++CFLAGS_NONANSI=$(C_OPT) $(ABI) $(NON_ANSI_C_FLAG) $(C_WARNINGS) $(DEFINES) \
++ $(INCLUDES)
++
++## C++ compiler
++## This part defines C++ compiler information
++
++# C++ compiler executable
++CCC=g++
++
++# C++ compiler ANSI/NON-ANSI flags
++ANSI_C_PLUS_FLAG=-ansi
++NON_ANSI_C_PLUS_FLAG=-traditional-cpp
++C_PLUS_WARNINGS=$(WARNINGS) $(NO_DEPRECATED)
++
++# This variable specifies how to compile the C code. If it is set to C,
++# that indicates that C code will be compiled with the C++ compiler.
++# Otherwise it will be compiled with C compiler.
++EXT=c
++
++# C++ compiler flags
++C++FLAGS=$(CCC_OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) $(DEFINES) \
++ $(INCLUDES)
++C++FLAGS_NONANSI=$(CCC_OPT) $(ABI) $(NON_ANSI_C_PLUS_FLAG) $(C_PLUS_WARNINGS) \
++ $(DEFINES) $(INCLUDES)
++# C++FLAGS_RELAXED should be set to avoid warnings reported by third party
++# source code that is not maintained by PDB
++C++FLAGS_RELAXED=$(OPT) $(ABI) $(ANSI_C_PLUS_FLAG) $(NO_DEPRECATED) $(DEFINES) \
++ $(INCLUDES)
++
++## Fortran compiler
++## This part defines Fortran compiler information
++
++# Fortran compiler executable
++F77=gfortran
++
++# Fortran compiler flags
++FFLAGS=$(F_OPT)
++
++# Additional Fortran libraries
++F77LIBS=
++
++#------------------------------------------------------------------------#
++
++#-----Linkers section----------------------------------------------------#
++
++# Static linking option. If not defined, dynamic linking is used.
++STATIC_LINKING=-static
++
++# Linker flags
++LDFLAGS=$(ABI) -w $(STATIC_LINKING)
++LDFLAGS_NO_STATIC=$(ABI) -w
++
++# Fortran linker
++F77_LINKER=gfortran
++
++#------------------------------------------------------------------------#
++
++#-----Archiver section---------------------------------------------------#
++
++# Archiver executable
++AR=ar
++
++# Archiver flags
++AR_GETFLAGS=xv
++AR_PUTFLAGS=rcvs
++
++#------------------------------------------------------------------------#
++
++#-----Ranlib-------------------------------------------------------------#
++
++RANLIB=true
++
++#------------------------------------------------------------------------#
++
++#-----Installer----------------------------------------------------------#
++
++INSTALL=../etc/cifinstall
++INSTALLOPTS=-m 0444
++
++#------------------------------------------------------------------------#
++
++#-----Stripper-----------------------------------------------------------#
++
++STRIP=strip
++
++#------------------------------------------------------------------------#
++
++#-----Shell--------------------------------------------------------------#
++
++SHELL=/bin/sh
++
++#------------------------------------------------------------------------#
+diff -urN -x cifparse-obj-v6.3 -x make.log -x Makefile.platform validation-v8.061-prod-src.orig/etc/platform.sh validation-v8.061-prod-src/etc/platform.sh
+--- validation-v8.061-prod-src.orig/etc/platform.sh 2004-08-20 08:26:48.000000000 -0700
++++ validation-v8.061-prod-src/etc/platform.sh 2005-12-18 15:38:53.000000000 -0800
+@@ -39,23 +39,31 @@
+ ;;
+
+ Linux)
+-# Check if it is GCC version 3.x
+- gcc_ver=`gcc --version | grep -e " 3\."`
++# Check if it is GCC version 4.x
++ gcc_ver=`gcc --version | grep -e " 4\."`
+ if [[ -z $gcc_ver ]]
+ then
+-# It is not GCC version 3.x. Check if it is GCC version 2.x
+- gcc_ver=`gcc --version | grep -e "2\."`
++# It is not GCC version 4.x. Check if it is GCC version 3.x
++ gcc_ver=`gcc --version | grep -e " 3\."`
+ if [[ -z $gcc_ver ]]
+ then
+-# It is not GCC version 2.x either. Production can not be compiled.
+- sysid="unknown"
++# It is not GCC version 3.x. Check if it is GCC version 2.x
++ gcc_ver=`gcc --version | grep -e "2\."`
++ if [[ -z $gcc_ver ]]
++ then
++# It is not GCC version 2.x either. Production can not be compiled.
++ sysid="unknown"
++ else
++# It is GCC version 2.x
++ sysid="gnu2"
++ fi
+ else
+-# It is GCC version 2.x
+- sysid="gnu2"
++# It is GCC version 3.x
++ sysid="gnu3"
+ fi
+ else
+-# It is GCC version 3.x
+- sysid="gnu3"
++# It is GCC version 4.x
++ sysid="gnu4"
+ fi
+ ;;
+
+diff -urN -x cifparse-obj-v6.3 -x make.log -x Makefile.platform validation-v8.061-prod-src.orig/Makefile validation-v8.061-prod-src/Makefile
+--- validation-v8.061-prod-src.orig/Makefile 2004-08-20 08:26:46.000000000 -0700
++++ validation-v8.061-prod-src/Makefile 2005-12-18 16:32:50.000000000 -0800
+@@ -59,7 +59,7 @@
+ echo "------------------------------------------------------------"; \
+ echo "**** Making $$libdir ****"; \
+ echo "------------------------------------------------------------"; \
+- (cd $$libdir && $(MAKE) -f $(MAKEFILE) "OPT=-O" install) || exit 1; \
++ (cd $$libdir && $(MAKE) -f $(MAKEFILE) C_OPT="${CFLAGS}" CCC_OPT="${CXXFLAGS}" F_OPT="${FFLAGS}" install) || exit 1; \
+ done
+
+ binary:
diff --git a/sci-chemistry/validation/metadata.xml b/sci-chemistry/validation/metadata.xml
new file mode 100644
index 000000000000..211b8bd0f0a4
--- /dev/null
+++ b/sci-chemistry/validation/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+<email>spyderous@gentoo.org</email>
+<name>Donnie Berkholz</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/validation/validation-8.061.ebuild b/sci-chemistry/validation/validation-8.061.ebuild
new file mode 100644
index 000000000000..9b76ddee9f81
--- /dev/null
+++ b/sci-chemistry/validation/validation-8.061.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/validation/validation-8.061.ebuild,v 1.1 2005/12/19 01:27:20 spyderous Exp $
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}-v${PV}-prod-src"
+DESCRIPTION="Set of tools used by the PDB for processing and checking structure data"
+HOMEPAGE="http://sw-tools.pdb.org/apps/VAL/index.html"
+SRC_URI="http://sw-tools.pdb.org/apps/VAL/${MY_P}.tar.gz"
+LICENSE="PDB"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/respect-flags-and-add-gcc4.patch
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CCC=\).*:\1$(tc-getCXX):g" \
+ ${S}/etc/make.*
+
+# -e "s:^\(CC=\).*:\1$(tc-getCC):g" \
+# -e "s:^\(F77=\).*:\1${FORTRANC}:g" \
+# -e "s:^\(F77_LINKER=\).*:\1${FORTRANC}:g" \
+
+# Do this with a patch
+# # Respect flags
+# sed -i \
+# -e "s:\(\"OPT=-O\"\):\"C_OPT=\"${CFLAGS}\" CCC_OPT=\"${CXXFLAGS}\" F_OPT=\"${FFLAGS:- -O2}\"\":g" \
+# ${S}/Makefile
+
+}
+
+src_compile() {
+ emake || die "make failed"
+ emake binary || die "make binary failed"
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe bin/*
+ insinto /usr/lib/rcsb/data/binary
+ doins data/binary/*
+ insinto /usr/lib/rcsb/data/ascii
+ doins data/ascii/*
+
+ echo "RCSBROOT=\"/usr/lib/rcsb\"" > ${T}/env.d
+ newenvd ${T}/env.d 50validation
+
+ dodoc README-source README
+}
+
+pkg_postinst() {
+ einfo "The source version does not install PROCHECK."
+ einfo "If you require that, you may download it from"
+ einfo "http://www.biochem.ucl.ac.uk/~roman/procheck/procheck.html."
+}