summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild')
-rw-r--r--sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild15
1 files changed, 12 insertions, 3 deletions
diff --git a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
index ecf92df7d9d9..3b5f0e1b16de 100644
--- a/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
+++ b/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild
@@ -1,14 +1,15 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild,v 1.5 2010/12/20 08:44:08 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/pdb2pqr/pdb2pqr-1.7.0.ebuild,v 1.6 2011/04/12 17:37:53 arfrever Exp $
EAPI="3"
+PYTHON_DEPEND="2:2.5"
SUPPORT_PYTHON_ABIS="1"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
RESTRICT_PYTHON_ABIS="2.4 3.*"
-inherit autotools distutils eutils flag-o-matic multilib toolchain-funcs versionator
+inherit autotools eutils flag-o-matic python toolchain-funcs versionator
MY_PV=$(get_version_component_range 1-2)
MY_P="${PN}-${MY_PV}"
@@ -143,3 +144,11 @@ src_install() {
dodoc ChangeLog NEWS README AUTHORS || \
die "Failed to install docs"
}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}