summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/prosite/prosite-19.9.ebuild')
-rw-r--r--sci-biology/prosite/prosite-19.9.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sci-biology/prosite/prosite-19.9.ebuild b/sci-biology/prosite/prosite-19.9.ebuild
new file mode 100644
index 000000000000..97e2c3865162
--- /dev/null
+++ b/sci-biology/prosite/prosite-19.9.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/prosite/prosite-19.9.ebuild,v 1.1 2005/09/01 22:14:58 ribosome Exp $
+
+DESCRIPTION="A protein families and domains database"
+HOMEPAGE="http://ca.expasy.org/prosite"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="swiss-prot"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~ppc-macos ~ppc64"
+IUSE="emboss minimal"
+# Minimal build keeps only the indexed files (if applicable) and the documentation.
+# The non-indexed database is not installed.
+
+DEPEND="emboss? ( >=sci-biology/emboss-3.0.0 )"
+
+src_compile() {
+ if use emboss; then
+ mkdir PROSITE
+ echo
+ einfo "Indexing PROSITE for usage with EMBOSS."
+ EMBOSS_DATA="." prosextract -auto -prositedir ${S} || die \
+ "Indexing PROSITE failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins ${PN}.{doc,dat,lis} || die
+ fi
+ dodoc *.txt || die
+ dohtml *.htm || die
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/PROSITE
+ doins PROSITE/* || die
+ fi
+}