summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/scamp/scamp-1.7.0-r1.ebuild')
-rw-r--r--sci-astronomy/scamp/scamp-1.7.0-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sci-astronomy/scamp/scamp-1.7.0-r1.ebuild b/sci-astronomy/scamp/scamp-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..585d5825ae02
--- /dev/null
+++ b/sci-astronomy/scamp/scamp-1.7.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/scamp/scamp-1.7.0-r1.ebuild,v 1.1 2012/01/03 02:43:12 bicatali Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Astrometric and photometric solutions for astronomical images"
+HOMEPAGE="http://www.astromatic.net/software/scamp"
+SRC_URI="http://www.astromatic.net/download/${PN}/${P}.tar.gz"
+
+LICENSE="CeCILL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc threads plplot"
+
+RDEPEND=">=sci-astronomy/cdsclient-3.4
+ virtual/cblas
+ >=sci-libs/lapack-atlas-3.8.0
+ sci-libs/fftw:3.0
+ plplot? ( sci-libs/plplot )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # gentoo uses cblas instead of ptcblas (linked to threaded with eselect)
+ sed -i \
+ -e 's/ptcblas/cblas/g' \
+ configure || die "sed failed"
+ epatch "${FILESDIR}"/${P}-plplot599.patch
+}
+
+src_configure() {
+ econf \
+ --with-atlas-incdir="${EROOT}/usr/include/atlas" \
+ $(use_with plplot) \
+ $(use_enable threads)
+}
+
+src_install () {
+ default
+ use doc && dodoc doc/*,pdf
+}