summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/ast/files/ast-5.1.0-makefile.in.patch')
-rw-r--r--sci-astronomy/ast/files/ast-5.1.0-makefile.in.patch90
1 files changed, 90 insertions, 0 deletions
diff --git a/sci-astronomy/ast/files/ast-5.1.0-makefile.in.patch b/sci-astronomy/ast/files/ast-5.1.0-makefile.in.patch
new file mode 100644
index 000000000000..99203524b5ed
--- /dev/null
+++ b/sci-astronomy/ast/files/ast-5.1.0-makefile.in.patch
@@ -0,0 +1,90 @@
+--- Makefile.in.orig 2009-03-20 20:05:18.314466717 +0000
++++ Makefile.in 2009-03-21 15:07:59.217879770 +0000
+@@ -77,7 +77,14 @@
+ "$(DESTDIR)$(includedir)" "$(DESTDIR)$(includedir)"
+ libLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(lib_LTLIBRARIES)
+-libast_la_LIBADD =
++libast_la_LIBADD = \
++ libast_err.la \
++ libast_grf3d.la \
++ libast_grf_2.0.la \
++ libast_grf_3.2.la \
++ libast_pal.la \
++ libast_wcslib.la
++
+ am__objects_1 = libast_la-axis.lo libast_la-box.lo libast_la-c2f77.lo \
+ libast_la-channel.lo libast_la-circle.lo libast_la-cmpframe.lo \
+ libast_la-cmpmap.lo libast_la-cmpregion.lo \
+@@ -163,10 +170,10 @@
+ libast_pal_la_LIBADD =
+ am_libast_pal_la_OBJECTS = libast_pal_la-pal.lo
+ libast_pal_la_OBJECTS = $(am_libast_pal_la_OBJECTS)
+-libast_pgplot_la_LIBADD =
++libast_pgplot_la_LIBADD = -lpgplot
+ am_libast_pgplot_la_OBJECTS = libast_pgplot_la-grf_pgplot.lo
+ libast_pgplot_la_OBJECTS = $(am_libast_pgplot_la_OBJECTS)
+-libast_pgplot3d_la_LIBADD =
++libast_pgplot3d_la_LIBADD = -lpgplot
+ am_libast_pgplot3d_la_OBJECTS = libast_pgplot3d_la-grf3d_pgplot.lo
+ libast_pgplot3d_la_OBJECTS = $(am_libast_pgplot3d_la_OBJECTS)
+ libast_wcslib_la_LIBADD =
+@@ -682,7 +689,6 @@
+ nodist_include_HEADERS = ast.h AST_PAR
+ include_MESSAGES = AST_ERR ast_err.h
+ lib_LTLIBRARIES = \
+- libast.la \
+ libast_err.la \
+ libast_ems.la \
+ libast_drama.la \
+@@ -692,11 +698,12 @@
+ libast_pgplot.la \
+ libast_pgplot3d.la \
+ libast_pal.la \
+- libast_wcslib.la
++ libast_wcslib.la \
++ libast.la
+
+-stardocs_DATA = @STAR_LATEX_DOCUMENTATION@
+-dist_starnews_DATA = ast.news
+-dist_pkgdata_DATA = LICENCE
++stardocs_DATA =
++dist_starnews_DATA =
++dist_pkgdata_DATA =
+
+ # Make all library code position independent by default. This is handy for
+ # creating shareable libraries from the static ones (Java JNI libraries).
+@@ -813,7 +820,7 @@
+ #ast_test_LDADD = `ast_link`
+ # Expand ast_link to avoid libast_pass2, which causes problems for Solaris
+ ast_test_LDADD = libast.la libast_pal.la libast_grf_3.2.la libast_wcslib.la libast_grf_2.0.la libast_grf3d.la libast_err.la -lm
+-starfacs_DATA = fac_1521_err
++starfacs_DATA =
+ all: $(BUILT_SOURCES) config.h
+ $(MAKE) $(AM_MAKEFLAGS) all-am
+
+@@ -2608,7 +2615,6 @@
+ echo "</files>"; \
+ echo "</manifest>"; \
+ ) >$$MF; \
+- $(INSTALL_DATA) $$MF $(DESTDIR)$(STAR_MANIFEST_DIR)/$(PACKAGE); \
+ else \
+ echo "Installation of component $(DESTDIR)$(STAR_MANIFEST_DIR)/$(PACKAGE) failed" >&2; \
+ fi; \
+@@ -2762,14 +2768,14 @@
+ $(mkdir_p) $(DESTDIR)$(libdir)
+ cd $(DESTDIR)$(libdir); \
+ for f in `ls libast.*`; do \
+- ff=`echo $$f | sed -e 's/libast/libast_pass2/'`; \
++ ff=`echo $$f | sed -e 's/libast\./libast_pass2\./'`; \
+ if test -f "$$ff"; then rm "$$ff"; fi; \
+ $(LN_S) $$f $$ff; \
+ $(MANIFEST) && echo "MANIFEST:$(DESTDIR)$(libdir)/$$ff" || :; \
+ done; \
+ if test -f "libast.la"; then \
+ if test -f "libast_pass2.la"; then rm "libast_pass2.la"; fi; \
+- sed -e 's/libast/libast_pass2/g' libast.la > libast_pass2.la; \
++ sed -e 's/libast\./libast_pass2\./g' libast.la > libast_pass2.la; \
+ fi
+ @PREDIST@version.h: version.h.in configure.ac
+ @PREDIST@ rm -f $@; $(predist_subs) version.h.in >$@