summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-zope/zope-interface/zope-interface-4.0.5.ebuild')
-rw-r--r--net-zope/zope-interface/zope-interface-4.0.5.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/net-zope/zope-interface/zope-interface-4.0.5.ebuild b/net-zope/zope-interface/zope-interface-4.0.5.ebuild
deleted file mode 100644
index 066ae767420a..000000000000
--- a/net-zope/zope-interface/zope-interface-4.0.5.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope-interface/zope-interface-4.0.5.ebuild,v 1.9 2014/06/23 14:43:36 floppym Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-inherit distutils-r1 flag-o-matic
-
-MY_PN="${PN/-/.}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Interfaces for Python"
-HOMEPAGE="http://pypi.python.org/pypi/zope.interface"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="ZPL"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- app-arch/unzip"
-RDEPEND=""
-
-S="${WORKDIR}/${MY_P}"
-
-# until all deps are in the tree (bug #442794)
-RESTRICT="test"
-
-python_compile() {
- if [[ ${EPYTHON} != python3* ]]; then
- local CFLAGS="${CFLAGS}" CXXFLAGS="${CXXFLAGS}"
- append-flags -fno-strict-aliasing
- fi
-
- distutils-r1_python_compile
-}
-
-python_test() {
- esetup.py test
-}