summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/mod_dav/files/mod_dav-shared-expat.patch')
-rw-r--r--net-www/mod_dav/files/mod_dav-shared-expat.patch160
1 files changed, 160 insertions, 0 deletions
diff --git a/net-www/mod_dav/files/mod_dav-shared-expat.patch b/net-www/mod_dav/files/mod_dav-shared-expat.patch
new file mode 100644
index 000000000000..fe8a89dd6686
--- /dev/null
+++ b/net-www/mod_dav/files/mod_dav-shared-expat.patch
@@ -0,0 +1,160 @@
+diff -urp mod_dav-1.0.3-1.3.6/config.h.in mod_dav-1.0.3-1.3.6.new/config.h.in
+--- mod_dav-1.0.3-1.3.6/config.h.in Mon Nov 5 00:04:48 2001
++++ mod_dav-1.0.3-1.3.6.new/config.h.in Tue Mar 5 03:33:43 2002
+@@ -1,7 +1,7 @@
+ /* config.h.in. Generated automatically from configure.in by autoheader. */
+
+ /* define to use Expat 2 */
+-#undef HAVE_EXPAT_2
++#define HAVE_EXPAT_2
+
+ /* Define if you have the ANSI C header files. */
+ #undef STDC_HEADERS
+diff -urp mod_dav-1.0.3-1.3.6/configure mod_dav-1.0.3-1.3.6.new/configure
+--- mod_dav-1.0.3-1.3.6/configure Mon Nov 5 00:04:50 2001
++++ mod_dav-1.0.3-1.3.6.new/configure Tue Mar 5 03:31:12 2002
+@@ -2196,20 +2196,20 @@ if test "${with_expat+set}" = set; then
+ withval="$with_expat"
+
+ if test "$withval" != "no" ; then
+- if test -f "$withval/include/xmlparse.h" ; then
++ if test -f "$withval/include/expat.h" ; then
+ XML_DIR=$withval
+ XML_INCLUDE="$withval/include"
+ XML_LIB="$withval/lib"
+ fi
+ if test "$XML_DIR" = "" ; then
+- if test -f "$withval/include/xml/xmlparse.h" ; then
++ if test -f "$withval/include/xml/expat.h" ; then
+ XML_DIR=$withval
+ XML_INCLUDE="$withval/include/xml"
+ XML_LIB="$withval/lib"
+ fi
+ fi
+ if test "$XML_DIR" = "" ; then
+- if test -f "$withval/include/xmltok/xmlparse.h"; then
++ if test -f "$withval/include/xmltok/expat.h"; then
+ # Debian
+ XML_DIR=$withval
+ XML_INCLUDE="$withval/include/xmltok"
+@@ -2218,7 +2218,7 @@ if test "${with_expat+set}" = set; then
+ fi
+ fi
+ if test "$XML_DIR" = "" ; then
+- if test -f "$withval/libexpat.a" -a -f "$withval/xmlparse/xmlparse.h" ; then
++ if test -f "$withval/libexpat.a" -a -f "$withval/xmlparse/expat.h" ; then
+ XML_DIR=$withval
+ XML_INCLUDE="$withval/xmlparse"
+ XML_LIB=$withval
+@@ -2253,15 +2253,15 @@ fi;
+ #
+ if test "$XML_DIR" = ""; then
+ if test -n "$APXS"; then
+- if test -f "$APXS_INCLUDE/xml/xmlparse.h"; then
++ if test -f "$APXS_INCLUDE/xml/expat.h"; then
+ XML_DIR=$APXS_INCLUDE
+ XML_INCLUDE="$APXS_INCLUDE/xml"
+ fi
+ else
+- if test -f "$APACHE_BASE/src/lib/expat-lite/xmlparse.h" ; then
++ if test -f "$APACHE_BASE/src/lib/expat-lite/expat.h" ; then
+ XML_DIR="$APACHE_BASE/src/lib/expat-lite"
+ XML_INCLUDE=$XML_DIR
+- elif test -f "$APACHE_INCLUDE/xml/xmlparse.h" ; then
++ elif test -f "$APACHE_INCLUDE/xml/expat.h" ; then
+ XML_DIR="$APACHE_INCLUDE/xml"
+ XML_INCLUDE=$XML_DIR
+ fi
+@@ -2273,15 +2273,15 @@ fi
+ #
+ if test "$XML_DIR" = ""; then
+ for i in /usr /usr/local ; do
+- if test -f "$i/include/xmlparse.h"; then
++ if test -f "$i/include/expat.h"; then
+ XML_DIR=$i
+ XML_INCLUDE="$i/include"
+ XML_LIB="$i/lib"
+- elif test -f "$i/include/xml/xmlparse.h"; then
++ elif test -f "$i/include/xml/expat.h"; then
+ XML_DIR=$i
+ XML_INCLUDE="$i/include/xml"
+ XML_LIB="$i/lib"
+- elif test -f "$i/include/xmltok/xmlparse.h"; then
++ elif test -f "$i/include/xmltok/expat.h"; then
+ # Debian
+ XML_DIR=$i
+ XML_INCLUDE="$i/include/xmltok"
+diff -urp mod_dav-1.0.3-1.3.6/configure.in mod_dav-1.0.3-1.3.6.new/configure.in
+--- mod_dav-1.0.3-1.3.6/configure.in Sat Nov 3 09:48:13 2001
++++ mod_dav-1.0.3-1.3.6.new/configure.in Tue Mar 5 03:31:12 2002
+@@ -144,20 +144,20 @@ AC_ARG_WITH(expat,
+ default search.],
+ [
+ if test "$withval" != "no" ; then
+- if test -f "$withval/include/xmlparse.h" ; then
++ if test -f "$withval/include/expat.h" ; then
+ XML_DIR=$withval
+ XML_INCLUDE="$withval/include"
+ XML_LIB="$withval/lib"
+ fi
+ if test "$XML_DIR" = "" ; then
+- if test -f "$withval/include/xml/xmlparse.h" ; then
++ if test -f "$withval/include/xml/expat.h" ; then
+ XML_DIR=$withval
+ XML_INCLUDE="$withval/include/xml"
+ XML_LIB="$withval/lib"
+ fi
+ fi
+ if test "$XML_DIR" = "" ; then
+- if test -f "$withval/include/xmltok/xmlparse.h"; then
++ if test -f "$withval/include/xmltok/expat.h"; then
+ # Debian
+ XML_DIR=$withval
+ XML_INCLUDE="$withval/include/xmltok"
+@@ -166,7 +166,7 @@ AC_ARG_WITH(expat,
+ fi
+ fi
+ if test "$XML_DIR" = "" ; then
+- if test -f "$withval/libexpat.a" -a -f "$withval/xmlparse/xmlparse.h" ; then
++ if test -f "$withval/libexpat.a" -a -f "$withval/xmlparse/expat.h" ; then
+ XML_DIR=$withval
+ XML_INCLUDE="$withval/xmlparse"
+ XML_LIB=$withval
+@@ -194,15 +194,15 @@ AC_ARG_WITH(expat,
+ #
+ if test "$XML_DIR" = ""; then
+ if test -n "$APXS"; then
+- if test -f "$APXS_INCLUDE/xml/xmlparse.h"; then
++ if test -f "$APXS_INCLUDE/xml/expat.h"; then
+ XML_DIR=$APXS_INCLUDE
+ XML_INCLUDE="$APXS_INCLUDE/xml"
+ fi
+ else
+- if test -f "$APACHE_BASE/src/lib/expat-lite/xmlparse.h" ; then
++ if test -f "$APACHE_BASE/src/lib/expat-lite/expat.h" ; then
+ XML_DIR="$APACHE_BASE/src/lib/expat-lite"
+ XML_INCLUDE=$XML_DIR
+- elif test -f "$APACHE_INCLUDE/xml/xmlparse.h" ; then
++ elif test -f "$APACHE_INCLUDE/xml/expat.h" ; then
+ XML_DIR="$APACHE_INCLUDE/xml"
+ XML_INCLUDE=$XML_DIR
+ fi
+@@ -214,15 +214,15 @@ fi
+ #
+ if test "$XML_DIR" = ""; then
+ for i in /usr /usr/local ; do
+- if test -f "$i/include/xmlparse.h"; then
++ if test -f "$i/include/expat.h"; then
+ XML_DIR=$i
+ XML_INCLUDE="$i/include"
+ XML_LIB="$i/lib"
+- elif test -f "$i/include/xml/xmlparse.h"; then
++ elif test -f "$i/include/xml/expat.h"; then
+ XML_DIR=$i
+ XML_INCLUDE="$i/include/xml"
+ XML_LIB="$i/lib"
+- elif test -f "$i/include/xmltok/xmlparse.h"; then
++ elif test -f "$i/include/xmltok/expat.h"; then
+ # Debian
+ XML_DIR=$i
+ XML_INCLUDE="$i/include/xmltok"