summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/apache/apache-1.3.34-r11.ebuild')
-rw-r--r--net-www/apache/apache-1.3.34-r11.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/net-www/apache/apache-1.3.34-r11.ebuild b/net-www/apache/apache-1.3.34-r11.ebuild
index cadcfb5cd4e8..0d2e40c8f4b3 100644
--- a/net-www/apache/apache-1.3.34-r11.ebuild
+++ b/net-www/apache/apache-1.3.34-r11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.34-r11.ebuild,v 1.8 2006/02/06 00:16:13 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-1.3.34-r11.ebuild,v 1.9 2006/04/19 17:24:59 chtekk Exp $
inherit eutils fixheadtails multilib
@@ -144,11 +144,13 @@ src_compile() {
fi
}
-src_install() {
+pkg_preinst() {
# setup apache user and group
enewgroup apache 81
enewuser apache 81 -1 /var/www apache
+}
+src_install() {
# general install
make install-quiet root=${D} || die
dodoc ABOUT_APACHE Announcement INSTALL LICENSE README* ${GENTOO_PATCHDIR}/docs/robots.txt