summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/dbhub/dbhub-0.437.ebuild')
-rw-r--r--net-p2p/dbhub/dbhub-0.437.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-p2p/dbhub/dbhub-0.437.ebuild b/net-p2p/dbhub/dbhub-0.437.ebuild
new file mode 100644
index 000000000000..adccc3d9ea49
--- /dev/null
+++ b/net-p2p/dbhub/dbhub-0.437.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/dbhub/dbhub-0.437.ebuild,v 1.1 2007/05/01 09:25:30 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="Hub software for Direct Connect, fork of opendchub"
+HOMEPAGE="http://dbhub.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="perl nls"
+
+DEPEND="perl? ( dev-lang/perl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch ${FILESDIR}/dbhub-gentoo.patch
+}
+
+src_compile() {
+ econf \
+ $(use_enable nls lang) \
+ $(use_enable perl) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc Documentation/*
+}