summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libtorrent/libtorrent-0.7.4.ebuild')
-rw-r--r--net-libs/libtorrent/libtorrent-0.7.4.ebuild35
1 files changed, 0 insertions, 35 deletions
diff --git a/net-libs/libtorrent/libtorrent-0.7.4.ebuild b/net-libs/libtorrent/libtorrent-0.7.4.ebuild
deleted file mode 100644
index 27543cb5f542..000000000000
--- a/net-libs/libtorrent/libtorrent-0.7.4.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.7.4.ebuild,v 1.1 2005/09/18 10:31:17 flameeyes Exp $
-
-inherit eutils toolchain-funcs flag-o-matic
-
-DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
-HOMEPAGE="http://libtorrent.rakshasa.no/"
-SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86"
-
-IUSE="debug"
-
-RDEPEND=">=dev-libs/libsigc++-2"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.11"
-
-src_compile() {
- [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
-
- econf \
- $(use_enable debug) \
- --disable-dependency-tracking \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-}