summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libgsasl/libgsasl-0.1.1.ebuild')
-rw-r--r--net-libs/libgsasl/libgsasl-0.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/libgsasl/libgsasl-0.1.1.ebuild b/net-libs/libgsasl/libgsasl-0.1.1.ebuild
new file mode 100644
index 000000000000..41d0b30d0923
--- /dev/null
+++ b/net-libs/libgsasl/libgsasl-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libgsasl/libgsasl-0.1.1.ebuild,v 1.1 2004/07/06 00:38:42 langthang Exp $
+
+DESCRIPTION="The GNU SASL (Simple Authentication and Security Layer)"
+HOMEPAGE="http://www.gnu.org/software/gsasl/"
+UPST_SRC=$P.tar.gz
+SRC_URI="ftp://alpha.gnu.org/pub/gnu/gsasl/${UPST_SRC}"
+LICENSE="LGPL-2.1"
+SLOT="0"
+# TODO: check http://www.gnu.org/software/gsasl/#dependencies for more
+# optional external libraries.
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="kerberos nls static"
+DEPEND="virtual/libc
+ nls? ( sys-devel/gettext )
+ kerberos? ( virtual/krb5 )"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} $(use_enable kerberos gssapi)"
+ myconf="${myconf} $(use_enable nls)"
+ myconf="${myconf} $(use_enable static)"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall
+ dodoc ABOUT-NLS AUTHORS COPYING ChangeLog NEWS README README-alpha THANKS
+}