summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ldns/ldns-1.6.3-r1.ebuild')
-rw-r--r--net-libs/ldns/ldns-1.6.3-r1.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/net-libs/ldns/ldns-1.6.3-r1.ebuild b/net-libs/ldns/ldns-1.6.3-r1.ebuild
deleted file mode 100644
index 285ee733aefa..000000000000
--- a/net-libs/ldns/ldns-1.6.3-r1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ldns/ldns-1.6.3-r1.ebuild,v 1.1 2010/01/11 03:17:24 matsuu Exp $
-
-EAPI="2"
-inherit eutils
-
-DESCRIPTION="ldns is a library with the aim to simplify DNS programing in C"
-HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
-SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc ssl vim-syntax"
-
-RDEPEND="ssl? ( >=dev-libs/openssl-0.9.7 )"
-DEPEND="${DEPEND}
- doc? ( app-doc/doxygen )"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-r3151-fix-double-free.patch"
-}
-
-src_configure() {
- econf \
- $(use_enable ssl sha2) \
- $(use_with ssl) \
- --disable-rpath || die "econf failed"
-}
-
-src_compile() {
- emake || die "emake failed"
- if use doc ; then
- emake doxygen || die "emake doxygen failed"
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc Changelog README* || die "dodoc failed"
-
- if use doc ; then
- dohtml doc/html/* || die "dohtml failed"
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect
- doins libdns.vim || die "doins libdns.vim failed"
- fi
-}